Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - Backoffice Protheus - Doc. Eletrônicos - NFE - Rejeição 452 - Solicitada resposta assíncrona para Lote com somente 1 (uma) NF-e.

Ocorrência
Ao realizar a transmissão de uma NF-e em ambiente de homologação ocorre a rejeição 452, como proceder?

Ambiente
Segmento - TOTVS Backoffice (Linha Protheus) - Todas as versões

Causa
Essa rejeição começou a ser apresentada após uma nova regra da Sefaz entrar em vigor dia 02/06/2025 em ambiente de homologação e 13/10/2025 em ambiente de produção, exigindo que transmissões de notas individuais sejam geradas através do método síncrono.

Solução
1. Realizar a aplicação do pacote abaixo no RPO do TSS, conforme release do ambiente:

TSS 12.1.2210 - 3.0 (somente para clientes com garantia estendida): Clique aqui para download.
TSS 12.1.2310 - 3.0: (somente para clientes com garantia estendida): Clique aqui para download.
TSS 12.1.2410 - 3.0: Clique aqui para download.

A partir de 30/06/2025 apenas clientes com garantia estendida conseguem aplicar patchs ou utilizar RPO atualizado na versão 12.1.2310, maiores informações no link abaixo:
- Garantia Estendida TOTVS Backoffice Linha 12.1.2310

IMPORTANTE - AMBIENTES CLOUD
- Para ambientes de TSS Cloud Compartilhado TOTVS, os mesmos já estão devidamente atualizados e contemplando essa atualização.
- Para ambientes de TSS Cloud Dedicado/Exclusivo TOTVS, deverá ser solicitado essa atualização para a equipe do Cloud.

Lembrando que a nível de transmissão, não há nenhum procedimento adicional a ser realizado, o próprio TSS internamente valida se a transmissão é de uma ou múltiplas notas e realiza a montagem de forma esperada pela Sefaz (assíncrona ou síncrona).

Documentação
- https://tdn.totvs.com/pages/releaseview.action?pageId=960027496

Esse artigo foi útil?
Usuários que acharam isso útil: 1 de 2

25 Comentários

  • Avatar
    CARLOS AUGUSTO DA COSTA MARQUES

    Quando atualizo o tss com o rpo que está disponível nesse link, ele não sobe mais e quando tento aplicar os patches no rpo da produção recebo vários erros de função duplicada. 

    8
    Ações de comentário Permalink
  • Avatar
    David Carvalho

    Tambem estamos com este problema....

    0
    Ações de comentário Permalink
  • Avatar
    Thiago Alessandro de Souza

    Essa mensagem começou hoje

    0
    Ações de comentário Permalink
  • Avatar
    Raphael Santos

    Transmitindo mais de uma NF por lote não ocorre esse erro.

    1
    Ações de comentário Permalink
  • Avatar
    CRISTIANO DA SILVA

    Após aplicação dessa patch, está dando INTERNAL SERVER ERROR
    No console aparece:
    THREAD ERROR ([22664], JOB_WS, THIS)   01/09/2025 12:52:55
    SPED050: DB error (Insert): -27 File: SPED050 - Error : 515 (23000) (RC=-1) - [Microsoft][ODBC Driver 11 for SQL Server][SQL Server]Cannot insert the value NULL into column 'NFE_PROT', table 'DADOSP12.dbo.SPED050'; column does not allow nulls. INSERT fails.
    Warning : 3621 (01000) (RC=-1) - [Microsoft][ODBC Driver 11 for SQL Server][SQL Server]The statement has been terminated.
    Error : 3621 (00000) (RC=-1) - 
     ( From tISAMFile::Write )
    Thread ID [25612]    User [Totvs Services SPED Gateway]    IO [1541]    Tables [75]    MaxTables [76]    Comment [[JOB_WS] WSServer SOAP REQUEST (NFESBRA:REMESSA) em 20250901 12:52:54  (running)]    SP [ ]    Traced [No]    SQLReplay [No]    InTran [No]    DBEnv [MSSQL/DADOSP12]    DBThread [(SPID 1542,1546)]    Started [01/09/2025 12:52:21]    IP [192.168.101.244:5169]    IDLE [ ]    InTransact [ ]    Memory [0]    Running [ROP_WRITE for 0 s.]    RCV [81005]    SND [1133775]    TCBuild [20240224-20250818]    TCVersion [24.1.0.7]    ARCH [64]    OS [WINDOWS]    BUILD [RELEASE]    
    INSERT INTO dbo.SPED050(D_E_L_E_T_,R_E_C_D_E_L_,R_E_C_N_O_) VALUES ( ?,?,?)

     

    0
    Ações de comentário Permalink
  • Avatar
    LUIZ ANTONIO BOUTH LOBATO

    Estou também com esse problema, peço apoio urgente, pois pelo que vi só atualizando o TSS.

    0
    Ações de comentário Permalink
  • Avatar
    CRISTIANO DA SILVA

    Luiz, o seu está dando INTERNAL SERVER ERROR ?

    0
    Ações de comentário Permalink
  • Avatar
    Leandro Marcelino

    Boa tarde, no meu caso estou com o TSS 12.1.033, tem algum procedimento para essa versão?

    0
    Ações de comentário Permalink
  • Avatar
    Craitson Mayer

    boa tarde

     

    para a rejeicao 452 aplicar o patch no RPO do TSS, levanta ele exclusivo e aguarda a criação dos indices Cross Segmentos - Backoffice Protheus - Doc. Eletrônicos - NFE - Rejeição 452 - Solicitada resposta assíncrona para Lote com somente 1 (uma) NF-e.

     

    apos isso irá dar rejeicao 853 ai aplica este patch e ou ajusta direto no rdmake do nfesefaz https://centraldeatendimento.totvs.com/hc/pt-br/articles/33846212287511-Cross-Segmentos-Backoffice-Protheus-Doc-Eletr%C3%B4nicos-NFE-Rejei%C3%A7%C3%A3o-853-Dados-de-cobran%C3%A7a-n%C3%A3o-devem-ser-informados-para-pagamento-a-vista

    0
    Ações de comentário Permalink
  • Avatar
    Paulo Xavier

    Aplicamos o RPO por completo a opção 3 porém na tela de transmissão fica travada, dando o erro SPED

    0
    Ações de comentário Permalink
  • Avatar
    Paulo Xavier

    Aguem tem alguma solução???

    0
    Ações de comentário Permalink
  • Avatar
    David Carvalho

    Conforme disse o Raphael Santos, transmitindo mais de uma NFe da certo..... 

     

    0
    Ações de comentário Permalink
  • Avatar
    Craitson Mayer

    A unica opção q funcionou para mim foi a 2º 

    0
    Ações de comentário Permalink
  • Avatar
    Adenildo Macêdo Almeida

    Qual dos Patch deve ser aplicado no RPO do TSS ?

    Pontual ou acumulado ?

     

    Att,

    0
    Ações de comentário Permalink
  • Avatar
    Suzanna Paizan

    Aqui só deu certo aplicando o patch pontual e atualizando os binários do TSS

    0
    Ações de comentário Permalink
  • Avatar
    MARCELO LOPES DE MOURA

    Alguém com erro Rejeição 865

    1
    Ações de comentário Permalink
  • Avatar
    Anderson Pelegrini Galleni

    Ontem passamos por um sufoco lascado. Estamos com a versão 12.1.2310 e sem garantia estendida. Em outubro pretendo migrar para a 2510. Conseguimos contornar as duas rejeições da seguinte maneira:

    Rejeição 452: Enviando novamente a última NF já transmitida e validada + a NF que precisa ser enviada, passa, foi possível transmitir.

    Rejeição 853: Inserimos no pedido de venda uma condição de pagamento com "1 dia" de prazo e TES que gera duplicata, passou também, foi possível transmitir.

    Não apliquei patch algum.

    Aparentemente tudo certo, pelo menos por enquanto. Ufa! rsrs...

    0
    Ações de comentário Permalink
  • Avatar
    TERMOTECNICA

    alguém conseguiu resolver o problema do INTERNAL SERVER ERROR quando acessa o monitor dou tss ou quando tenta excluir uma nota?

     

    2
    Ações de comentário Permalink
  • Avatar
    Guilherme Henrique de Oliveira Natal

    Galera, lendo os comentários, eu mantive os RPO e apenas atualizei o acumulado. Funcionou aqui.

    0
    Ações de comentário Permalink
  • Avatar
    DANIELLI ROCHA

    Consegui resolver REJEIÇÃO 452 da seguinte forma:

    Com Login Adm, Alterei o parâmetro de tempo de espera da transmissão da NF-e para 0, e funcionou. NF-e Sefaz/ Outras Ações/ Parâmetros/ NF-e/ Tempo de espera=0
    Obs: para transmissão de apenas 1 NF.
    Espero ter ajudado. 

     

    1
    Ações de comentário Permalink
  • Avatar
    Cristiane Nogueira

    Boa tarde, as Nfs so foram transmitidas pq a Sefaz prorrogou  conforme Nota Tenica emitda hoje 02/09 prorrogarão ate 13/10.

    0
    Ações de comentário Permalink
  • Avatar
    Analista Suporte Rech

    Boa tarde, 

    Alguem percebeu se esta prorrogação ja esta on-line ?

    0
    Ações de comentário Permalink
  • Avatar
    CRISTIANO DA SILVA

    TERMOTECNICA
    Sim, resolvemos esse problema no INTERNAL SERVER ERROR, refazendo a tabela SPED050. Deixar MV_VERDB em branco

    1
    Ações de comentário Permalink
  • Avatar
    Adenildo Macêdo Almeida

    Após aplicar essa correção, o MDFe passou dar rejeição 611

    0
    Ações de comentário Permalink
  • Avatar
    Izildo Aparecido Tozete

    Boa tarde, e quem não tem a garantia estendida, o que deve ser feito?

    0
    Ações de comentário Permalink
Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _