Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

RH - RM - FOP - Crédito do Trabalhador - A cadeia de caracteres de entrada não estava em um formato correto


time.png Tempo aproximado para leitura: 00:03:05 min

Ocorrência
Ao realizar a importação do arquivo Crédito Trabalhador, o sistema emite a seguinte mensagem de erro: A cadeia de caracteres de entrada não estava em um formato correto.

Ambiente

TOTVS RH - TOTVS RH (Linha RM) - TOTVS Folha de Pagamento - A partir dos patches:

12.1.2406.277

12.1.2410.229

12.1.2502.145

12.1.2506 e superiores


Causa

A mensagem de erro "A cadeia de caracteres de entrada não estava em um formato correto" pode ser gerada por diferentes tipos de inconsistências no arquivo Crédito Trabalhador. O erro não aponta uma causa específica, podendo estar relacionado a mais de uma situação distinta no conteúdo do arquivo.

 

Solução
Para solucionar o erro apresentado, verifique os seguintes pontos:

1. CPF/CNPJ sem zeros a esquerda: 

  • Devido a uma falha na plataforma do governo, os arquivos estão sendo gerados sem os zeros à esquerda nos campos de CPF e CNPJ iniciados com zero. O governo informou que realizará os ajustes necessários na plataforma nas próximas competências. Enquanto isso, as empresas deverão corrigir manualmente os dados no arquivo antes de realizar a importação. Para mais informações, verifique o link: RH - RM - FOP - Crédito do Trabalhador : CPF/CNPJ dos trabalhadores sem os zeros à esquerda.

2. Campos sem aspas duplas - Extensão JSON: 

  • Caso esteja utilizando a extensão .json, valide se todos os campos estão corretamente envolvidos por aspas duplas, conforme especificado no layout. A ausência dessas aspas em determinados campos pode causar falha na leitura e gerar a mensagem de erro. 

erro parse.png


A imagem acima destaca os campos que devem ser analisados e ajustados para conter aspas duplas, caso estejam em desacordo com o layout.

 

3. Formato incorreto dos meses em arquivos CSV editados no Excel:

  • Ao abrir ou editar o arquivo com extensão .csv diretamente no Excel, os campos 'CompetenciaInicioDesconto' e 'CompetenciaFimDesconto' podem ter os meses convertidos automaticamente para o formato textual (por exemplo, mai/25). No entanto, o formato correto exigido pelo layout é numérico (05/25).

    Recomenda-se revisar esses campos antes de importar o arquivo, garantindo que estejam no formato adequado.



Importante:

Se você baixar o arquivo novamente e editá-lo com um editor de texto, como o Bloco de Notas ou Notepad++, esse problema não ocorrerá.

 

Saiba Mais: 

Importação Empréstimos FEBRABAN / Crédito do Trabalhador

Layout Crédito do Trabalhador

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _