Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Fluig - Plataforma - ARQ - Erro ao acessar recursos no menu Soluções

Ocorrência
Foi constatado que estão ocorrendo erros ao acessar os recursos do menu Soluções (Pages, Forms e Tasks). Observando o log do servidor, são apresentadas as mensagens abaixo:

  Caused by: java.sql.SQLSyntaxErrorException: ORA-00933: comando SQL não encerrado
  adequadamente
  Caused by: org.hibernate.exception.SQLGrammarException: could not extract ResultSet

Por que esse erro está ocorrendo? Como resolver?

Ambiente
TOTVS Fluig Plataforma - Arquitetura e Ambiente - A partir da versão 1.6.5 (Liquid) | Banco de dados: Oracle

Causa
As funcionalidades disponíveis no menu Soluções são microsserviços independentes que utilizam um framework de object relacional com versão (5.2.17) superior a versão (5.0.10) do framework na plataforma. Com isso, em comunicações com o banco de dados Oracle, estão sendo utilizadas propriedades de dialeto distintas (um dialeto para microsserviços e outro para a plataforma), ocasionando o erro apresentado acima (SQLGrammarException).

Solução
Para corrigir o problema, não há necessidade de nova atualização com patch, basta incluir a propriedade abaixo no arquivo domain.xml localizado em [diretório_instalação]/appserver/domain/configuration.

<system-properties>
<property name="spring.jpa.properties.hibernate.dialect" value="org.hibernate.dialect.Oracle10gDialect"/>
</system-properties>

Importante
Após a inclusão da propriedade os serviços devem ser reiniciados.

A partir da versão Voyager 2.0, as configurações foram migradas dos arquivos domain.xml e host.xml para o standalone.xml. Este artigo se refere às versões anteriores ao Voyager 2.0.
Para mais informações sobre a migração e as diferenças entre as versões, consulte nossa documentação Atualização Voyager (2.0) - O arquivo de configurações da plataforma mudou!

Saiba Mais
Caso a situação não tenha sido resolvida, confira também o artigo Fluig - Plataforma - ARQ - Erro 401 Unauthorized ao tentar acessar recursos do menu Soluções

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _