Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Fluig - Plataforma - CON - Erro 401 Unauthorized ao tentar acessar recursos do menu Soluções

Ocorrência
A mensagem de erro abaixo é exibida diversas vezes no log:

Discovery not available yet for storage. Cause: FLUIG_REST_CLIENT_401. Help: Make sure that the server where fluig is installed has access to the address: http://endereco_fluig.com:8080. Verifique se o servidor onde está instalado o fluig tem acesso ao endereço: http://endereco_fluig.com:8080

Além disso, as páginas Tasks, Pages e Forms do menu Soluções não estão funcionando.
O que pode estar causando esse erro? Como resolver?

solu__es.png

Ambiente
TOTVS Fluig Plataforma - Configurações técnicas - A partir da versão 1.6.5 (Liquid)

Causa
Já foi constatada a causa desse erro, e a correção foi liberada na release 1.6.5-190528.

Solução
Para resolver essa ocorrência, siga os passos abaixo:

1. Atualize seu ambiente para a última versão disponível no Portal.

2. Em seguida, antes de iniciar os serviços do Fluig, acesse o arquivo domain.xml localizado em [diretório_instalação]\appserver\domain\configuration\.

  • Verifique a variável FLUIG_URL. Ela deve estar configurada com o IP interno do servidor da plataforma e a porta interna da plataforma, como no exemplo abaixo. Eles precisam estar acessíveis via telnet ou nestats, por exemplo.
<property name="FLUIG_URL" value="http://10.80.80.17:8080"/>
  • Além disso, verifique se o IP configurado na variável FLUIG_URL consta na variável NETWORK_IP_ADDRESSES, como no exemplo abaixo.
<property name="NETWORK_IP_ADDRESSES" value="127.0.0.1,127.0.0.1,0:0:0:0:0:0:0:1,10.80.80.17,fe80:0:0:0:fc45:ca9b:4482:6956%eth3,10.80.66.58,fe80:0:0:0:e50f:61aa:775:fb99%wlan0,fe80:0:0:0:c531:695e:9de6:1f81%wlan1,fe80:0:0:0:b1e6:22ea:be7:fe1%wlan2,fe80:0:0:0:0:5efe:a50:423a%net4,fe80:0:0:0:0:5efe:a50:5011%net4"/>
  • Verifique também a existência da rewrite (<rewrite name="http-to-https" redirect="true" target="url_cliente"/>). Ela não é padrão e força a comunicação em HTTPS. Se ela existir, remova-a.

3. Por último, faça a limpeza das pastas temporárias, reinicie os serviços do Fluig e realize um novo teste.

Importante!

Caso realize as configurações deste artigo e o erro ainda persista, confira as seguintes questões que podem ser feitas para solucionar a situação:

  • Digite a seguinte url no seu navegador:  http://[seuendereço fluig]/discovery/api/v1/services e nos envie um print do resultado, ou também a mensagem que aparecer em tela, assim poderemos verificar se é uma mensagem de erro ou sucesso.

  • Limpe o cache do navegador ou acesse a plataforma de uma aba anônima, e veja se o menu Soluções pode ser acessado.

  • Acesse o seu endereço dentro do servidor da plataforma. E verifique se consegue acessar seu endereço sem problemas ou se ocorre alguma inconsistência no acesso.

  • Por fim, revise suas configurações de acordo com a documentação Proxy Reverso.
Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _