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Fluig - Plataforma - BPM - O que significa a mensagem: "Usuário XXXXXX não está apto a receber a tarefa" (atividades de processos)

Ocorrência
Na Transferência de pendências, ao transferir atividades de processos, é exibida a mensagem:

================================================================================
=== Verificando Transferência de Tarefas Workflow Pendentes ===
[ERROR] Tarefa pendente do workflow (Corrigir Solicitacao - Solicitação: 21138) não pode ser transferida para o colaborador 123 (Usuário 123 não está apto a receber a tarefa.).


Ambiente
TOTVS Fluig Plataforma - Processos - Todas as versões.

Causa
O usuário selecionado como destino para receber as atividades não está no mecanismo de atribuição da atividade atual do processo. Muitas vezes o mecanismo de atribuição está configurado como "Por executor de atividade", "Por campo de formulário" ou "Por usuário".

Se uma dessas opções estiver configurada no mecanismo de atribuição da atividade de destino, o retorno da lista sempre será um usuário que não é o usuário de destino da transferência, então a mensagem de erro será apresentada.

Isso pode ocorrer também caso o cliente tenha algum mecanismo de atribuição customizado que retorne apenas um usuário e o usuário retornado nesse mecanismo não seja o usuário selecionado como destino da transferência de pendências.

Exemplo:
Se o Mecanismo de Atribuição da atividade tiver sido configurado "Por usuário" e o usuário selecionado for Ronaldo, não será possível transferir esta pendência para João, pois o mecanismo da atividade não aceita outro usuário que não seja o Ronaldo.
Se Ronaldo e João pertencessem a um mesmo grupo e o mecanismo de atribuição da atividade fosse "Por Grupo", a transferência poderia ser realizada normalmente.


Solução

1. Verificar se no processo em questão foi configurado gestor, pois o usuário que é gestor tem as mesmas permissões que o usuário que se encontra com a tarefa, podendo inclusive movimentar, cancelar ou transferir para outro usuário.

Para os casos em que a atividade atual estiver configurada com esses mecanismos ou que o mecanismo só retorna um usuário que não é o usuário de destino, a alternativa é acessar o Fluig com o usuário de destino e realizar a transferência de atividade acessando a solicitação pela Central de Tarefas.

2. Verificar se o desenvolvedor do processo definiu que a atividade não permite transferência, desta maneira, o sistema bloqueará quaisquer tentativas de transferência de pendências:

Atividade configurada para não permitir transferência

Observação:

Quando estiver utilizando mecanismo por campo de formulário, será necessário alterar no campo o usuário destino, para então fazer a transferência.

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Usuários que acharam isso útil: 1 de 1

2 Comentários

  • Avatar
    Fabio Todeschini Tonietto

    Em grande parte dos cenários, o pessoal acaba colocando por usuário, o que acaba gerando resultando problemas posteriores depois. Muito bem explicado!

    1
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  • Avatar
    HUBERTH GUILHERME FERREIRA DE ANDRADE

    O fluig deveria conceder a permissão para que o Admin movimente, transfira ou cancele qualquer solicitação independente do modo a qual ela foi configurada.

    Não faz sentido ser Admin com limitações.

    0
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Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

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Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

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Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

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Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

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