Ocorrência
Ao tentar realizar o login na plataforma, a mensagem Código de usuário já cadastrado é exibida na tela de login. Por que isso ocorre?
Ambiente
TOTVS Fluig Plataforma - Usuários - A partir da versão 1.6.0
Causa
Isso pode acontecer quando o e-mail do usuário foi alterado no Identity depois que o usuário já havia sido provisionado na plataforma.
Solução
Para corrigir, é preciso apagar o usuário do TOTVS Identity e cadastrá-lo novamente com o e-mail correto. Se o e-mail é gerenciado no AD, exclua o usuário no Identity, ajuste o e-mail no AD e importe-o novamente.
Em seguida, acesse a plataforma com um usuário administrador e navegue até Painel de Controle > Usuários.
Edite o cadastro do usuário e o campo e-mail estará liberado para alteração. Ajuste o e-mail para o valor correto (o mesmo do Identity) e salve. Nesse momento a plataforma irá automaticamente vincular o usuário com o cadastro correspondente no Identity.
Agora tente fazer login na plataforma através do Identity. O usuário não deverá ter problemas.
Saiba mais
Acesse o artigo Como alterar o e-mail de um usuário na plataforma integrada ao Identity para mais informações sobre alteração de e-mail.
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