Ocorrência
Os documentos não estão sendo visualizados na plataforma, apresentando a mensagem: Erro ao gerar a visualização do arquivo. Caso possua permissão, utilize a opção de download do documento.
O que pode estar causando esse erro e como resolver?
Ambiente
TOTVS Fluig Plataforma - Documentos - Todas as versões
Causa
Há duas causas comuns para essa situação: proxy reverso ou ambiente com HTTPS. Para detectar, é necessário analisar o log gerado com a visualização.
Solução
Para resolver esse problema, siga os passos abaixo:
1. Tente visualizar um documento e assim que a mensagem de erro acontecer faça o download do log para analisá-lo. O log pode ser baixado no Painel de Controle > Controle de log através do botão Baixar log do servidor completo.
2. Verifique se uma das mensagens ERROR abaixo é exibida no seu arquivo:
INFO [com.totvs.technology.ecm.viewer.DocumentViewerUrlServlet] (default task-30) internalVisualizerServer: http://api.accusoft.com.br
ERROR [com.totvs.technology.ecm.viewer.DocumentViewerUrlServlet] (default task-1) Connection failed and the session will be stopped: Connection timed out (Connection timed out): java.net.ConnectException: Connection timed out (Connection timed out)
2020-11-13 09:19:41,305 INFO [com.totvs.technology.ecm.accusoft.viewer.DocumentViewerUrlServlet] (default task-290) oldViewer: null
2020-11-13 09:19:41,308 INFO [com.totvs.technology.ecm.accusoft.viewer.DocumentViewerUrlServlet] (default task-290) internalVisualizerServer: https://api.accusoft.com.br
2020-11-13 09:19:41,309 INFO [com.totvs.technology.ecm.accusoft.viewer.DocumentViewerUrlServlet] (default task-290) allowsHttpForInternalVisualizerServer: false
2020-11-13 09:19:41,423 ERROR [com.totvs.technology.ecm.accusoft.viewer.DocumentViewerUrlServlet] (default task-290) Connection failed and the session will be stopped: Connection refused (Connection refused): java.net.ConnectException: Connection refused (Connection refused)
Se uma dessas mensagens for apresentada, há necessidade de configuração do proxy reverso. O que acontece nesse caso é que o visualizador monta uma URL de stream do documento, o servidor recebe esse endereço e não o reconhece.
Para corrigir isso, é necessário efetuar a Configuração de Proxy Reverso, para que o servidor entenda aquele prefixo na URL de stream como se fosse seu próprio endereço e consiga realizar a visualização dos documentos.
3. Verifique também se a mensagem ERROR abaixo é exibida no seu arquivo. Nesse caso é necessário fazer outra configuração no ambiente. Confira os detalhes a seguir.
2019-08-26 10:39:45,589 INFO
[com.totvs.technology.ecm.viewer.DocumentViewerUrlServlet] (default task-5) internalVisualizerServer: https://api.accusoft.com.br
2019-08-26 10:39:46,102 ERROR
[com.totvs.technology.ecm.viewer.DocumentViewerUrlServlet] (default task-5) Connection failed and the session will be stopped: sun.security.validator.ValidatorException: PKIX path building failed:
sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target: javax.net.ssl.SSLHandshakeException: sun.security.validator.ValidatorException: PKIX path building failed:
sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target
Faça o download do certificado da Accusoft como detalhado no GIF abaixo:
Se o fluig estiver em um servidor Windows, acesse o Prompt de comando e execute o comando abaixo substituindo <FLUIG_DIR> pelo caminho onde o fluig está instalado e <CERT_FILE> pelo caminho onde o certificado da Accusoft foi baixado (exemplo: C:\Users\admin\Downloads\api.accusoft.com.br.cer).
<FLUIG_DIR>\jdk-64\bin\keytool.exe -import -alias accusoft -keystore "<FLUIG_DIR>\jdk-64\lib\security\cacerts" -file "<CERT_FILE>"
Uma senha será solicitada. Informe changeit.
Reinicie o fluig para finalizar a configuração.
Se o fluig estiver em um servidor Linux, acesse o terminal e execute o comando abaixo substituindo <FLUIG_DIR> pelo caminho onde o fluig está instalado e <CERT_FILE> pelo caminho onde o certificado da Accusoft foi baixado (exemplo: C:\Users\admin\Downloads\api.accusoft.com.br.cer).
<FLUIG_DIR>\jdk-64\bin\keytool -import -alias accusoft -keystore "<FLUIG_DIR>\jdk-64\lib\security\cacerts" -file "<CERT_FILE>"
Uma senha será solicitada. Informe changeit.
Reinicie o fluig para finalizar a configuração.
Atenção!
Se você estiver acessando a plataforma com HTTPS, utilize a URL https://api.accusoft.com.br. Se estiver acessando com HTTP, utilize a URL http://api.accusoft.com.br. Revise a configuração conforme orientação da documentação de Configuração do Fluig Viewer.
Verifique também se falta importar o certificado HTTPS, além do certificado da Accusoft. Também reforçamos que é necessário reiniciar o fluig a cada importação.
Saiba Mais
Consulte também o artigo: Fluig - Plataforma - ECM - Documento modificado externamente ao Fluig
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