Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmento - Backoffice (Linha Protheus) - SIGAEST - A330CONTAB - Erro de Aplicação na Thread de Contabilização

O erro A330CONTAB ocorre durante a contabilização no TOTVS Protheus, relacionado a variáveis ou regras incorretas no Lançamento Padrão (LP). Para corrigir, localize o erro no console.log, identifique a LP acionada, analise as variáveis na STACK, ajuste a regra incorreta e reprocese a rotina. O problema geralmente envolve variáveis inexistentes ou mal configuradas no ADVPL.

time.png Tempo aproximado para leitura: 00:03:00 min

Ocorrência
Durante o processamento da etapa de contabilização, ocorre o erro: A330CONTAB - Erro de Processamento/Thread de Contabilização como corrigir?

Ambiente
Cross Segmento - TOTVS Backoffice (Linha Protheus) - Estoque/Custos - Todas as versões.
 

Causa 
O erro A330CONTAB está diretamente relacionado com o processo de Lançamento Padrão (LP). Esse erro ocorre quando uma variável ou regra usada em um lançamento padrão está incorreta ou não foi encontrada no momento da execução, e pode retomar vários erros por exemplo:

- variable does not exist
- JOB threads doesn't support remote/visual componentes
- type mismatch on +

Ou outros, não importa qual, se retornar A330CONTAB é um problema pontual no Lançamento.

Segue exemplos de como pode aparecer em seu sistema:


Solução
Quando o erro ocorre no processo de Acompanha Custos, ele é registrado no arquivo console.log, onde é possível realizar uma busca utilizando o título do erro: "Sub-Processo: A330CONTAB". Esse filtro vai trazer o cabeçalho do erro, seguido de informações adicionais que ajudam a identificar o ponto exato da falha, como o campo TRC_LANTRC/CPADRAO, que indica a última LP acionada.

 

variable does not exist TESTE on DETPROVA(MATXFUNA.PRX)

Isso significa que o sistema não encontrou a variável TESTE dentro da função DETPROVA, no código-fonte MATXFUNA.PRX.

O erro está relacionado com uma regra específica do Lançamento Padrão registrado no campo TRC_LANTRC, que, neste caso, é o lançamento 666. Assim, o próximo passo é investigar onde essa regra está definida e como ela está sendo utilizada na LP.

Após identificar a LP no TRC_LANTRC (neste caso, a LP 666), filtre a STACK e verifique as condições usadas no código. Ao fazer isso, encontramos que a variável CVALOR(C) contém apenas o nome TESTE, exatamente a variável que causou o erro na chamada.

STACK DETPROVA(MATXFUNA.PRX) 30/09/2024 10:30:01

Isso ajuda a localizar onde o erro ocorreu durante o processamento.

Após identificar que a variável TESTE está incorretamente configurada, é necessário ajustar a regra de acordo com a programação em ADVPL. Verifique se a variável TESTE realmente existe e, se necessário, substitua-a pela variável correta.

Nota: Neste exemplo, o uso incorreto da variável foi intencional para demonstrar o erro.

Depois de corrigir o erro na LP (Lançamento Padrão), processe novamente a rotina no sistema para verificar se o problema foi resolvido.

 

Pode ocorrer erro do tipo:

A330CONTAB - JOB threads doesn't support remote/visual componentes

A validação é a mesma, regra na LP ou até mesmo o acionamento de uma customização nas chamdas, que pode ser identificado pela inicial U_ na tela ou no erro.


Resumo do Processo:

  1. Localize o erro no arquivo console.log utilizando o filtro "Sub-Processo: A330CONTAB".
  2. Identifique a LP acionada através do campo TRC_LANTRC.
  3. Analise a chamada STACK e as variáveis utilizadas no código.
  4. Corrija a regra incorreta no lançamento padrão, ajustando a variável que causou o erro.
  5. Reprocessar a rotina para validar a correção.

Outro tipo de erro comum que pode ocorrer na contabilização é o erro da inexistencia de variavel, por exemplo:

variable does not exist NOME_DA_VARIAVEL on CTRELATION(MATXFUNC.PRX)

A sugestão, é buscar o nome da variavel em questão dentro do error.log, e caso seja um campo, valide se esse campo esta em um indice de forma incorreta, seja na tabela CT5/CTL ou propria tabela do campo.

 

Saiba mais:

Cross Segmento - Backoffice (Linha Protheus) - SIGAEST - Erro de aplicação na thread de Contabilização

Cross Segmento - Backoffice (Linha Protheus) - SIGAEST - Quais os Códigos dos Lançamentos Padronizados do Estoque?

Clique aqui e veja mais artigos sobre Custos no Estoque

 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _