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Cross Segmentos - TOTVS CRM Gestão de Clientes - Contas - Visualização de clientes com responsável

time.png Tempo aproximado para leitura: 00:01:00 min

Ocorrência
Ao pesquisar um cliente no CRM, mesmo ele tendo responsável, não aparece na busca, mas o usuário responsável consegue visualizar.

Ambiente
Cross Segmentos - TOTVS CRM Gestão de Clientes - Contas - Pesquisar cliente - Versão APP3

Causa
Esse cenário ocorre devido a 2 possíveis fatores:

  • A configuração de acesso global está definida por hierarquia de papeis.
  • O usuário responsável está sem papel definido.

 

Solução
Para cada fator é preciso analisar alguns pontos:

1. A configuração de acesso global está definida por hierarquia de papeis:

Neste caso é preciso verificar as configurações do Controle de Acesso que foram definidas e depois validar em qual papel o usuário responsável pela conta está alocado. Dependendo do papel e da configuração do acesso global, se o usuário que estiver fazendo a busca da conta, estiver com um papel abaixo da hierarquia do usuário responsável, ele não terá a visão.

Para essa situação, é preciso que o usuário responsável, compartilhe manualmente o registro com o outro usuário.

 

controle acesso.png

 

2. O usuário responsável está sem papel definido:

Depois de verificar as configurações de acesso global e validar que o usuário está sem um papel definido, todas as contas que estiverem atribuídas a ele, somente esse usuário terá acesso. Isso porque se ele não tiver um papel definido, ficará fora da hierarquia e consequentemente irá causar o cenário mencionado.

Nesse caso é preciso definir um papel ao usuário, seguindo a estrutura do organograma e a sua regra de negócio.

 

papel.png

 

Importante!

Ao realizar qualquer alteração nos papéis, é preciso realizar um novo login na aplicação para que as alterações sejam refletidas.

 

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