Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - TOTVS BackOffice Linha RM - TOTVS Gestão de Estoque, Compras e Faturamento - MOV - Erro FKTTMVEXT_GFORMULA

time.png Tempo aproximado para leitura: 00:03:00 min

Ocorrência
Ao realizar o processo de Copia de Movimento entre Coligadas, é apresentado o erro:  The INSERT statement conflicted with the FOREIGN KEY constraint FKTTMVEXT_GFORMULA {...}

Ambiente
Cross Segmentos - TOTVS BackOffice Linha RM - TOTVS Gestão de Estoque, Compras e Faturamento - Todas as versões.

Causa
Essa mensagem de erro é apresentada pois o movimento selecionado para realizar a copia entre coligadas possui campos preenchidos com fórmulas, e estas não possuem registro na coligada de destino selecionada no processo.

Solução
Pra que a mensagem de erro não seja apresentada durante a execução do processo, será necessário que as Fórmulas contidas no movimento sejam copiadas entre coligadas ou que sejam removidas do movimento.

Para realizar o processo entre coligadas clique na fórmula contida nos parâmetros do movimento > Processos > Copia de Fórmulas entre Coligadas. 

Outro caminho é no módulo Serviços Globais > menu Administração > Fórmulas > Sistema: Gestão de Estoque, Compras e Faturamento > Selecione a Fórmula > Processos > Copia de Fórmulas entre Coligadas. 

 

ETAPAS NO MOVIMENTO QUE PODEM CONTER FÓRMULAS:

  1. Etapa Mov - Outros Dados:



  2. Etapa Mov - Valores Financeiros 2/4:



  3. Etapa Mov - Campos Livres 2/2:



  4. Etapa Item - Identificação 1/2:



  5. Etapa Item - Valores Financeiros 1/2:



  6. Etapa Item - Campos Livres 2/2:



  7. Etapa Estoque - Estoque 2/3:
    Para que esse campo de fórmula seja apresentado, o campo Efeito Sobre o Saldo Atual precisa estar parametrizado = Aumenta.



  8. Etapa Estoque - Custo:



  9. Etapa Orçamento:
    Para esse campo ficar habilitado, é necessário que a flag Controla Orçamento esteja habilitada.



  10. Etapa Rateio C.Custo - Departamento:



  11. Etapa Fin - Faturamento 3/6:
    Para que esses campos fiquem habilitados, é necessário que esteja habilitada a flag "Fatura o Movimento" na etapa Fin - Faturamento 1/6



  12. Etapa Manutenção:



  13. Etapa Patrimônio:

Outros campos também podem apresentar erro durante a Copia de Movimento entre Coligadas por não conter a informação na coligada de destino. Mais informações:

Cross Segmentos - TOTVS BackOffice Linha RM - TOTVS Gestão de Estoque, Compras e Faturamento - MAT - Cópia de Tipo de Movimento entre Coligadas

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _