Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

RH - Linha Protheus - Meu RH - Um funcionário de um Grupo de Empresa, com mesma matrícula, consegue acessar dados do outro

time.png Tempo aproximado para leitura: 00:03:00 min

Ocorrência
Um funcionário de um Grupo de Empresa, com mesma matrícula, consegue acessar dados de um outro funcionário, de um outro Grupo de Empresa.

Ambiente
TOTVS RH Linha Protheus - Meu RH – Todas as versões

Causa
Este incidente pode ocorrer, pois dois funcionários que possuem o mesmo código de matrícula, entre Grupos de Empresas diferentes, possuem também o mesmo código de participante e o mesmo código de filial, e não realizam o logout para invalidar o Token de acesso.

Solução
Entre Grupos de Empresas diferentes, quando dois funcionários com a mesma matrícula, mesmo código de participante e o mesmo código de filial, utilizam o App Meu RH e, sem realizar logout, fecham a página, o Token de acesso não era invalidado, por isso, um conseguiria acessar o Meu RH do outro só alterando a URL de acesso ao Meu RH.

Cenário entre dois Grupos de Empresas:


Tendo mais confiabilidade no App Meu RH, foi implementado mais um mecanismo de segurança para, obrigatoriamente, deslogar o usuário da página, mesmo que este não acione o botão Sair, basicamente, se o App Meu RH identificar que houve troca de Grupo de Empresa por alguma alteração na URL, o Meu RH forçará o logout deste funcionário, para que um novo token de acesso seja gerado e o token antigo seja invalidado.

Para que, o ambiente esteja preparado à essa nova ferramenta de segurança, é obrigatório a atualização dos arquivos de front do App Meu RH, seguindo nossa documentação oficial.

Para melhor desempenho, é altamente recomendado que seja realizado, periodicamente, a limpeza do cache do navegador, procedimentos esse para que o endpoint seja carregado sem o cache, visando a sua devida atualização.

Saiba Mais
CLIQUE AQUI para acessar mais artigos e FAQs sobre o MEU RH
CLIQUE AQUI para acessar a documentação de referências sobre o MEU RH

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _