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Ocorrência
Um funcionário de um Grupo de Empresa, com mesma matrícula, consegue acessar dados de um outro funcionário, de um outro Grupo de Empresa.
Ambiente
TOTVS RH Linha Protheus - Meu RH – Todas as versões
Causa
Este incidente pode ocorrer, pois dois funcionários que possuem o mesmo código de matrícula, entre Grupos de Empresas diferentes, possuem também o mesmo código de participante e o mesmo código de filial, e não realizam o logout para invalidar o Token de acesso.
Solução
Entre Grupos de Empresas diferentes, quando dois funcionários com a mesma matrícula, mesmo código de participante e o mesmo código de filial, utilizam o App Meu RH e, sem realizar logout, fecham a página, o Token de acesso não era invalidado, por isso, um conseguiria acessar o Meu RH do outro só alterando a URL de acesso ao Meu RH.
Cenário entre dois Grupos de Empresas:
Tendo mais confiabilidade no App Meu RH, foi implementado mais um mecanismo de segurança para, obrigatoriamente, deslogar o usuário da página, mesmo que este não acione o botão Sair, basicamente, se o App Meu RH identificar que houve troca de Grupo de Empresa por alguma alteração na URL, o Meu RH forçará o logout deste funcionário, para que um novo token de acesso seja gerado e o token antigo seja invalidado.
Para que, o ambiente esteja preparado à essa nova ferramenta de segurança, é obrigatório a atualização dos arquivos de front do App Meu RH, seguindo nossa documentação oficial.
Para melhor desempenho, é altamente recomendado que seja realizado, periodicamente, a limpeza do cache do navegador, procedimentos esse para que o endpoint seja carregado sem o cache, visando a sua devida atualização.
Saiba Mais
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