Tempo aproximado para leitura: 00:10:00 min
Ocorrência
No módulo Financeiro, ao tentar realizar a transmissão de pagamentos via API - FINA717, ocorre a mensagem de erro "Falha na comunicação com o Banco do Brasil, verifique com o banco se o serviço de "Pagamentos em lote" está funcionando corretamente"
Ambiente
Cross Segmento - TOTVS Backoffice (Linha Protheus) - Financeiro - A partir da release 12.1.2210
Causa
A falha mais comum neste caso, será problemas de certificado, como falha na leitura abaixo
Exemplo abaixo
Caso a visualização de seu console.log esteja com a mensagem abaixo ou no retorno do Suporte, deve realizar algumas ações para novos testes e correção
CFGX060 Wizard de Conversão de Certificado
Realizar a conversão do certificado .PFX seguindo a documentação abaixo
Cross Segmentos - Backoffice Linha Protheus - SIGAFIN - Não foi possível gerar os arquivos corretamente Erro ao extrair o Certificado de Autorização no CFGX060 Wizard de Conversão de Certificado
Será gerado os arquivos *.CERT.PEM e *.KEY.PEM
Então os arquivos devem ser renomeados suas extensões para
De .CERT.PEM para CERT.CRT
De .KEY.PEM para .KEY.KEY
Após conversão e adicionados a pasta Protheus_data/Cert/NGF, adicione os certificados na FINA710 - Configuração de Contas para o Banco que irá realizar a transmissão de pagamentos
Posteriormente realize uma nova transmissão ou transmitir os títulos rejeitados.
Saiba mais:
0 Comentários