Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - Backoffice Linha Protheus - SIGAFIN - Não foi possível gerar os arquivos corretamente Erro ao extrair o Certificado de Autorização no CFGX060 Wizard de Conversão de Certificado

time.pngTempo aproximado para leitura: 00:09:00 min

Ocorrência

Ao Acessar o Configurador CFGX060 - Wizard de Conversão de Certificado e selecionar o arquivo .PFX para conversão apresenta a mensagem: 

"Não foi possível gerar os arquivos corretamente" Erro ao extrair o Certificado de Autorização no SIGACFG -Wizard de Conversão de Certificado".

 

Ambiente
Cross Segmentos - TOTVS BackOffice (Linha Protheus) - Financeiro - FINA710 - Todas as versões

 

Causa

Erro ao Extrair arquivos - CFGX060 - Wizard de Conversão de Certificado 

"Não foi possível gerar os arquivos corretamente" Erro ao extrair o Certificado de Autorização
dica3.png

 

Solução
Neste caso, pode verificar a data de validade do certificado, pois o Protheus irá validar a data de emissão e data de vencimento e a extensão PFX. (O arquivo PFX deve conter o tamanho inicial de 7KB para que tenha comunicação com o Protheus)
Exemplo
Como verificar a validade do Certificado Digital:
Acessar o opções da internet > Conteúdo >Certificados
unnamed__1_.png
Ao clicar no Campo Certificados > Localizar o Certificado na Aba Pessoal > Deve clicar 2x no mesmo e verificar o campo "Válido a partir de XX/XX/XXX até XX/XX/XXXX"
dica4.PNG
O arquivo deve conter a extensão .PFX e seu tamanho inicial de 7KB
Capturar.PNG
Após validação acessar o Protheus > Modulo Configurador> Cadastro> Wizard de Conversão de Certificado.
Assistente de Conversão de Certificado Digital e seguir as orientações abaixo:
O arquivo .PFX deve estar dentro da pasta system do ambiente Protheus
unnamed__2_.png
Nesse momento o Assistente Conversor irá converter o arquivo .PFX em arquivo extensão .PEM
unnamed__3_.png
IMPORTANTE:
Os Caminhos acima devem conter letras "Minúsculas", conforme exemplo acima, pois podem interferir na conversão dos arquivos
Caso o arquivo conter um tamanho menor do que 7KB, pode seguir as orientações da documentação do saiba mais "Cross Segmentos - Backoffice Protheus - Doc. Eletrônicos - Como Exportar e Aumentar o tamanho do arquivo .PFX ( Certificado Digital - modelo A1 )" ou pode entrar em contato com o órgão emissor do Certificado (Banco ou Certificadora) para verificar a possibilidade do aumento do tamanho, (Importação das Hierarquias AC no arquivo) devido aos requisitos do Protheus.

Saiba mais:
Esse artigo foi útil?
Usuários que acharam isso útil: 3 de 3

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _