Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmento - Backoffice Linha Protheus - SIGACTB - SIGAATF - SIGAPCO - Erro no processo de instalação de Procedure

Ocorrência:

Erros no processo de instalação de procedure como por exemplo:


Erro ao instalar a procedure [ATF004_11_XX] - Error : 24344 - ORA-24344: success with compilation error ( From tDBServer::ROP_SQLEXEC )

 

Ambiente:
Cross Segmento - TOTVS Backoffice Linha Protheus - Ativo Fixo -  Contábil - PCO

Causa:

Geralmente erros de instalação de procedures ocorrem devidos a desatualização, erros no código fonte, ou erros no ambiente.

Solução:
Para solucionar essa ocorrência, realize os seguintes passos:

- Realizar Backup do RPO
- Aplique as atualizações abaixo referente a procedure do módulo que ocorre o erro, em um ambiente de homologação

 

Links:
Pacotes de Atualização - Ativo Fixo + Dicionário + Procedure

Pacotes de Atualização - Contábil+ Dicionário + Procedure

Pacotes de Atualização - PCO + Dicionário + Procedure

 

Atualize o gestor de procedures :

https://tdn.totvs.com/pages/releaseview.action?pageId=532651679

 

E Diretamente no servidor realiza o processo abaixo em modo exclusivo:1º Reinicie o serviço.


1º Desinstale as procedures existente em seu ambiente.
2º Verifique se o sistema desinstalou do configurador.
3º Verifique se o sistema desinstalou do Banco antes de instalar novamente.
4º Instale as procedures .
5º Reinicie o serviço.

 

- Se o procedimento acima não corrigir, solicite ao DBA da empresa que realiza a consulta abaixo:

 

Executar a seguinte consulta para obter os erros de compilação específicos da procedure:

 

- Verificar qual procedure esta apresentando erro, como exemplo utilizamos a ATF004_11_XX

- Onde ATF004_11 faz referencia ao nome da procedure e XX é o numero do grupo de empresa.

 

Segue querys a serem realizadas, pelo DBA

--Oracle:

SELECT *
FROM user_errors
WHERE name = 'ATF004_11_01';

Esta consulta irá fornecer detalhes sobre os erros de compilação encontrados na
procedure.


--SQL

SELECT *
FROM sys.messages
WHERE language_id = 1033 -- ID do idioma inglês
AND text LIKE '%ATF004_11_01%'
AND severity > 10
AND is_event_logged = 0;

//language_id = 1033

  •  
  • 1033: Inglês (padrão)
  •  
  • 1046: Português
  •  
  • 1031: Alemão
  •  
  • 1034: Espanhol
  •  
  • 1036: Francês
  •  
  • 1040: Italiano


--Postgres

SELECT *
FROM pg_catalog.pg_proc p
WHERE p.proname = 'ATF004_11_01';

 

Após realizada a query colher os resultados e encaminha para o suporte para analise.

 

Saiba Mais:
Stored Procedures - Novo gerenciador de pacotes

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _