Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Framework - Linha Datasul - FRW - Erro 8186 - A chave informada no arquivo não atende ao formato padrão Datasul

time.png Tempo aproximado para leitura: 00:01:00 min

Ocorrência
Quando o Contas a Pagar ou o Contas a Receber não recebe no retorno escritural a mesma chave do envio escritural, ocorre o erro 8186 - A chave informada no arquivo não atende ao formato padrão Datasul.

Ambiente
Framework - Framework (Linha Datasul) - Eletronic Data Interchange (EDI) - Todas as versões

Causa
Este erro ocorre pois o conteúdo recebido referente ao ID do Registro, também conhecido como Seu Número, encontra-se incorreto ou em branco no retorno escritural, não sendo possível localizar o título. O formato utilizado como padrão para a chave do título é XXX;XXXXXX;X;, sendo que o formato é constituído por:

- Estabelecimento do Item do Borderô;Id do Item do Borderô;N; ou;

- Estabelecimento dos Itens do Borderô Agrupados;Id dos Itens do Borderô Agrupados;Y;.

Solução
Primeiramente é necessário conferir se o Seu Número está sendo gerado corretamente na remessa, ou seja, se o Seu Número extraído está sendo exportado pelo mapa EDI. Para isso, é necessário gerar o relatório Dados Layout Entrada/Saída EDI - EDU327AA. Caso o problema esteja na exportação, será necessário realizar o ajuste do mapa EDI.
Estando tudo correto na exportação, gerar o mesmo relatório, mas do processo de importação e avaliar se o Seu Número está sendo importado e efetivado corretamente para o financeiro. Caso o Seu Número esteja no arquivo de retorno mas não esteja aparecendo corretamente no relatório, deverá ser ajustado o mapa EDI para importar/efetivar o registro corretamente.
Outra situação que pode ocorrer é ter no arquivo de retorno segmentos que não possuem o Seu Número e que não são necessários na efetivação. Neste caso, é necessário criar um segmento genérico para ignorar a efetivação dos dados deste segmento.

 

Importante

Para mais informações sobre como gerar o relatório, acesse:
Framework - Linha Datasul - FRW - Dados de processos EDI para serem analisados
Informações sobre como criar o segmento genérico, acesse:
Framework - Linha Datasul - FRW - Cadastro de segmento genérico para que não ocorra o erro 8525

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _