Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

WINT - Mensagem "ORA-01400: não é possível inserir NULL em "XXX"."PCRECALCULOPROD" no Servidor de faturamento

Ocorrência
Ao tentar sincronizar as vendas na Central de Gerenciamento do servidor de faturamento, aparece, no log dos arquivos rejeitados, a mensagem "ORA-01400: não é possível inserir NULL em "XXX"."PCRECALCULOPROD.XXX"

Ambiente
TOTVS Distribuição Linha Winthor - 20 - Autosserviço -  A partir da versão 30

Causa

Esse incidente ocorre por incompatibilidade na estrutura de dados das versões das rotinas e do servidor de faturamento

Solução
Para solucionar essa ocorrência, realize os seguintes passos:

1. Atualize a rotina 560 (PCINFTAB) e atualize a tabela PCRECALCULOPROD;

2. Atualize a rotina 1100 e atualize a pkg_estoque;

3. Atualize o Servidor de Faturamento;

4. Atualize as Estruturas do banco;

5. Apague os arquivos rejeitados na Central de Gerenciamento do servidor de faturamento atualizado;

6. Sincronize as vendas.

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _