Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmento - Backoffice (Linha Protheus) - SIGAEST - Error : 31 - ORA-00031: session marked for kill em rotinas de Processamento


Ocorrência
Ao executar rotinas de Processamento no Protheus, como Fechamento de Estoque (Virada de Saldos) - MATA280 - ocorre o seguinte erro no banco de dados Oracle:

"Error : 31 - ORA-00031: session marked for kill: ORA-00028: your session has been killed".

Ambiente
Cross Segmento - TOTVS Backoffice (Linha Protheus) - Estoque/Custos - Todas as versões

 

Causa

Este erro ocorre no banco de dados Oracle, normalmente com as seguintes causas:

  • Sessão eliminada manualmente por usuário de banco de dados privilegiado;
  • Tempo limite do banco de dados (timed out);
  • Deadlock no banco de dados (quando o mesmo, por segurança, bloqueia para não haver duas ou mais transações simultaneamente).
  • Bug específico do Oracle no banco de dados;
  • Firewall ou outro problema de rede.


Solução
Para um melhor diagnóstico do que está causando este problema, a TOTVS recomenda que o usuário que esteja enfrentando este problema solicite o apoio da equipe de TI ou Administração do Banco de Dados (DBA) da empresa. Pois, se tratando de uma não conformidade do banco Oracle, basicamente por perder comunicação com os serviços do Protheus automaticamente o processamento não é concluído.

 

Saiba mais:

Cross Segmento - Backoffice (Linha Protheus) - SIGAEST - Roteiro para Fechamento de Estoque (virada de saldos)

Clique aqui e veja mais artigos sobre Processamentos no Estoque

Clique aqui e veja mais artigos sobre Fechamento de Estoque/Virada de Saldos

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _