FAQs - Suporte técnico

RH - Linha Protheus - GPE - Problema de performance/travamento ao efetuar o cálculo de férias


Ocorrência

Ao tentar efetuar o Cálculo de Férias, através da rotina GPEM030 gera problema de performance/travamento (demora no cálculo) no ambiente

Ambiente
TOTVS RH - TOTVS RH (Linha Protheus) - Ponto Eletrônico Todas as versões


Causa
O problema ocorre devido a rotina de Troca de Turnos possuir cadastrado apenas uma linha bastante antiga para o funcionário, onde o sistema acaba criando calendários anteriores até a data da última linha da Troca de Turno, gerando então a lentidão no cálculo

Solução
Para solucionar o problema verifique os pontos abaixo:
1. Este funcionário possui cadastrado alguma Troca de Turno na rotina em Atualizações/Ponto Eletrônico/Trocas de Turno conforme demonstrado abaixo:



2. Se o módulo de Ponto Eletrônico não é utilizado, a mesma rotina não precisa compreender com nenhum registro para o funcionário, devendo assim, deletar a informação

3. Se o módulo de Ponto Eletrônico é utilizado
, certifique-se de que o período do Ponto Eletrônico bata com o período da Folha e nesta rotina, conste linhas mês à mês de cada fechamento do Ponto.

Observação: Outra possibilidade pode ser o Mnemônico P_LMEMCALC (Memoria de calculo), quando o mesmo está ativado ele grava todo o processo efetuado em um arquivo fazendo com que o sistema apresente lentidão.
 

Saiba mais:
Pacote de Expedição Contínua do RH: https://centraldeatendimento.totvs.com/hc/pt-br/articles/360057829854
Pacote de Expedição Contínua do eSocial: https://centraldeatendimento.totvs.com/hc/pt-br/articles/360057829854 
Pacote de Expedição Contínua do Medicina e Segurança do Trabalho: https://centraldeatendimento.totvs.com/hc/pt-br/articles/360057956773

ChatBot Carol Assistant

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _