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Ocorrência
Quando há integração entre os módulos SIGATEC x SIGAPON, ao acessar as rotinas de manutenção do SIGAPON o calendário exibe todos os dias como "Não Trabalhado"
Ambiente
TOTVS Prestadores de Serviços - TOTVS Prestadores de Serviços Terceirização - SIGATEC - Todas as versões
Causa
Na integração entre o módulo de Prestadores de Serviços (SIGATEC) e o módulo de Ponto Eletrônico (SIGAPON), era utilizado o RDMAKE do ponto "PNMTABC01.PRW", esse RDMAKE realiza a montagem dos calendários do ponto e o processamento das marcações.
Porém, para versões a partir da 23 disponibilizamos o fonte através da criação do parâmetro MV_GSPNMTA.
Ao Habilitar o MV_GSPNMTA (.T.), caso o Funcionário não esteja vinculado à um Cadastro de Atendentes (TECA020), o sistema realizará a montagem do calendário do Ponto Eletrônico (SIGAPON) conforme Turno informado no Cadastro de Funcionários (GPEA010), porém, ao vincular o funcionário à um atendente, o calendário do Ponto Eletrônico (SIGAPON) passa a validar as agendas registradas na Mesa Operacional (TECA190D).
Dessa forma, caso o habilite o parâmetro MV_GSPNMTA (.T.), se não houverem agendas para esse Atendente na Mesa Operacional (TECA190D), o Ponto Eletrônico (SIGAPON) interpreta os dias como "Não Trabalhados".
Solução
1. Caso não necessite utilizar a integração entre o módulo Prestadores de Serviços (SIGATEC) e o módulo de Ponto Eletrônico (SIGAPON), retire o vínculo do funcionário com o Cadastro de Atendentes (TECA020) ou desabilite o parâmetro MV_GSPNMTA (.F.);
2. Caso necessite utilizar a integração entre o módulo Prestadores de Serviços (SIGATEC) e o módulo de Ponto Eletrônico (SIGAPON), realize a geração das agendas do Atendente na Mesa Operacional (TECA190D).
Saiba mais:
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