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RH - Linha Protheus - PON - Integração com o módulo Gestão de Serviços deixa o calendário no Ponto Eletrônico como Não Trabalhado

time.png Tempo aproximado para leitura: 00:02:00 min

Ocorrência
Quando existe integração entre os módulos Gestão de Serviços x Ponto Eletrônico, ao acessar as rotinas de manutenção do SIGAPON o calendário exibe todos os dias como Não Trabalhado:



Ambiente
TOTVS RH - TOTVS RH (Linha Protheus) - Ponto Eletrônico - A partir do release 12.1.23

Causa 
O cenário ocorre quando:
- O parâmetro MV_GSPNMTA está com conteúdo .T.
- Existe cadastro de Atendente, mas não existe alocação do atendente na Mesa Operacional, ambos cadastros existentes no módulo de Gestão de Serviços.

Solução
Para que o calendário do módulo de Ponto Eletrônico seja montado corretamente, será necessário que:
- O parâmetro MV_GSPNMTA seja definido com conteúdo .F.
OU
- Seja feita alocação do Atendente na rotina de Mesa Operacional dentro do módulo de Gestão de Serviços.

O parâmetro MV_TECXRH, também do módulo de Gestão de Serviços, serve para definir se a integração entre os módulos de Ponto Eletrônico e Gestão de Serviços está ativa ou não, além de enviar os dados de Cargo, Turno e Sequência do Turno vinculados ao Cadastro do Funcionário (SRA), para o cadastro do Atendente (AA1), porém, uma vez que o MV_GSPNMTA está ativo, se não existir alocação para o Atendente na Mesa Operacional, será entendido que não há jornada prevista no período, portanto, o calendário do Ponto Eletrônico será montado com todos os dias do período como Não Trabalhados. 
Importante ressaltar que isso ocorre mesmo se o MV_TECXRH estiver com conteúdo .F.

Saiba Mais:
Parâmetro MV_GSPNMTA
Parâmetro MV_TECXRH
Módulo Gestão de Serviços - SIGATEC

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