Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

RH - RM - FOP - Erro: FKPFHSTHOR_AHORARIO violada - chave mãe não localizada - Transferência entre coligadas


time.png Tempo aproximado para leitura: 00:03:00 min

Ocorrência
Erro FKPFHSTHOR_AHORARIO violada - chave mãe não localizada ao cadastrar transferência entre coligadas?

Ambiente
TOTVS RH - TOTVS RH (Linha RM) - TOTVS Folha de Pagamento - Todas as versões.

Causa
O erro apresentado é causado devido a incompatibilidade de registros na tabela de horário.

Solução

Para solucionar essa ocorrência, realize os seguintes passos:

1. Para que efetue a transferência de funcionários é necessário que efetue a cópia dos registros de horários de entre as coligadas envolvidas no processo.

RH - RM - FOP - Cópia de registros entre coligadas

2. Para que o erro FKPFHSTHOR_AHORARIO não seja apresentado durante a transferência do funcionário deverá acessar a coligada de destino e verificar se possui o mesmo sindicato do RM Chronus, vinculado atualmente ao funcionário na coligada de origem.


3-
Depois que clicar em anexo, seguir o passo a passo abaixo:

 

4- Todos os horários cadastrados pela empresa  (coligada origem) deverão estar contidos na coligada destino. (TODOS OS DADOS IGUAIS).

 

5- Caso não exista é necessário que efetue a copia dos Sindicatos do Chronus da Coligada Origem para Destino. No módulo Automação de Ponto acesse Automação de Ponto | Configurações | Parametrizador | Sindicato.

 

Importante
A transferência do funcionário é irreversível e não pode ser cancelada! Antes de executar o processo, tenha certeza das informações digitadas no cadastro da rescisão.

Para evitar que apareçam mais erros futuros, peço que copie todos os registros entre as coligadas.

Saiba mais
RH - RM - FOP - Cópia de registros entre coligadas 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _