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Cross Segmento - Backoffice (Linha Protheus) - SIGAEST - MATA038 - Acompanha Custos não abre/botão "Novo Fechamento" não habilita

time.png Tempo aproximado para leitura: 00:03:30 min

Ocorrência

A rotina Acompanha Custos (MATA038) não está mais abrindo, ficando com tela branca ou com o botão "Novo Fechamento" inativo. 

Tela branca:

 

Botão novo fechamento indisponível: 

botao novo fechamento inativo.png

Carregando eternamente:

Ambiente
Cross Segmento - TOTVS Backoffice (Linha Protheus) - Estoque/Custos - Todas as versões.

Causa
Esse incidente ocorre normalmente por falta de atualização de Componentes, onde rotinas PO-UI requisitam bastante da manutenção (atualização) periódica dos artefatos como: LIB, Binários e Dbaccess. O próprio código-fonte do da "Acompanha Custos" (MATA038) também é importante, porém normalmente são os artefatos que, conforme ficam obsoletos, podem enfrentar esse tipo de colateral.

Solução
Para solucionar essa ocorrência, realize os seguintes passos:

1. Atualizar os artefatos de Framework:

Observação: sempre aplicar pacotes primeiramente em ambiente de homologação com backup prévio do RPO.


2. Em caso de atualizações porém insucesso (permanência do problema), será necessário avaliar via Logs (gere e encaminhe ao Suporte Técnico:

 

Habilitação de TraceStack e geração de logs:

2.1. Habilite TraceStack no arquivo appserver.ini em um ambiente isolado, conforme a documentação: https://tdn.totvs.com/display/tec/TraceStack


2.2. Após habilitar a chave TraceStack, faça um backup do arquivo console.log (com outro nome) e o arquivo original console.log, limpe todo seu conteúdo. Este arquivo está contido no diretório do appserver. Em seguida reinicie o Sistema.

2.3. Depois de reiniciar o sistema, acesse à rotina "Acompanha Custos" e aguarde por cerca de 5 minutos.

2.4. Durante este período, o arquivo console.log será alimentado. Caso não tenha conhecimento/habilidade de análise de log, colete-o e encaminhe ao Suporte Técnico por meio de um ticket.

 

2.5. Encaminhar também os dados de ambiente via Central de Diagnósticos. Veja neste artigo como enviar através do atalho SHIFT + F6: Cross Segmento - Backoffice (Linha Protheus) - SIGAEST - Como enviar dados pela Central de Diagnóstico?

 

Saiba mais:

Clique aqui e veja mais artigos sobre Custos no Estoque

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