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Framework - Linha RM - Frame - Autorização de uso do sistema irá vencer ou licença está expirando

Framework - Linha RM - Frame - Autorização de uso do sistema irá vencer ou licença está expirando


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Ocorrência

Ao logar em qualquer aplicativo RM é apresentado o aviso A autorização de uso do sistema irá vencer em XX/XX/XX. Acesse o portal do cliente através do endereço 'http://suporte.totvs.com/gestaodelicencas' para identificar o motivo ou entre em contato com o CST - Centro de Serviços TOTVS.




Ambiente
Framework - Linha RM - Todas as versões do sistema RM

 

Causa
Falta de comunicação do servidor de licenças do cliente com os servidores da TOTVS (interrupção na atualização diária das licenças) ou License Server desatualizado.

Solução
Para correção da inconsistência, siga os passos abaixo:

      1. Avaliar se a versão do License Server está na 3.6.1 ou superior:




Para mais informações sobre como identificar a versão do License Server consulte o artigo
Framework - Linha RM - Frame - Identificar versão do License Server Virtual


Para realizar a atualização do License Server, siga os passos do artigo 
Framework - Linha RM - Frame - Atualização License Server Virtual

 

Caso o License Server Monitor esteja atualizado, realize os seguintes procedimentos:

  1. Acesse o TOTVS License Monitor (aplicativo do License Server). Caso tenha dúvidas sobre como acessar o TOTVS License Monitor, consulte o artigo: Framework - Linha RM - Frame - Acessar o TOTVS License Monitor
  2. Clique na antena, localizada no canto superior à direita, conforme print abaixo, para realizar a atualização manual:



  3. Após o término do processo anterior, clique em informação, localizado no canto superior à direita, conforme print abaixo:



  4. Avalie se a Data de geração da autorização de uso e Data de vencimento da autorização de uso estão atualizadas, conforme exemplo no print abaixo:



    Data de geração da autorização de uso: Data atual;
    Data de vencimento da autorização de uso: Data atual + 30 dias;

Importante

O TOTVS | License Server necessita de acesso à internet para sua instalação e operação.
O Acesso é realizado através do protocolo HTTPS e toda a comunicação é feita pela porta 443. Caso a sua empresa possua firewall e/ou restrições de acesso à internet, é necessário que o administrador da rede libere o acesso para o endereço https://lscloud.totvs.app/api/ (Este é o endereço base dos serviços do License Server). O tipo de conexão realizada é outbound (O License Server realiza uma chamada cliente a um servidor na Internet).

É possível executar a ferramenta HTTPANALYSER (disponível a partir da versão 1.03.016 do License Server) para verificar se o servidor onde o License Server será instalado está com a comunicação liberada com a Totvs. Maiores detalhes sobre a ferramenta no link:
HTTPANALYSER - Validação de Comunicação com a Web



O tráfego ocorrerá uma vez por dia no horário configurado pela TOTVS. Caso o acesso seja interrompido por mais de 15 dias, os usuários e/ou administradores dos softwares TOTVS serão notificados no Login do sistema.

Aviso
Utilize sempre o endereço DNS https://lscloud.totvs.app/api. A utilização do seu respectivo endereço IP pode causar interrupção na atualização diária das licenças caso a Totvs altere o endereço IP. Isso não fará com que o LS Virtual pare de funcionar de imediato, mas pela perda de comunicação diária, passará a exibir a mensagem de expiração da licença e obrigará uma intervenção manual de troca do IP ou alteração para o DNS (lscloud.totvs.app/api) na regra do seu servidor.

Mais informações em TOTVS License Server Virtual

 

Caso seja apresentado algum erro durante a sincronização, realize as verificações e configurações abaixo: 

1. Verifique as permissões no diretório DATA do License Server;

- Em Windows:
Clique com o botão direto do mouse na pasta Data;
Desmarque a opção Somente Leitura e aplique para todas as subpastas.

- Em Linux:
Acesse o diretório do License Server.
Execute o comando  chmod -R 777 data.

2. Verifique se está executando o serviço do License Server com o usuário Administrador do Sistema Operacional no servidor.

3. Verifique se o TOTVS ID configurado no License Server Virtual está bloqueado.
Caso esteja bloqueado, gentileza alterar o status para NÃO BLOQUEADO. Para confirmar, acesse o Portal do Cliente | Gestão de Licenças | aba Instalações
Detalhes no link abaixo:
CST - GSEN – Como Bloquear ou Desbloquear Instalações

Para confirmar o TOTVS ID utilizado, no monitor do License Server, clique no botão Informações, localizado no canto superior direito, ou abra o arquivo licenseserver.ini localizado no diretório Appserver da instalação do License Server.

4. Verifique se no servidor possui configuração de Proxy (mesmo que este seja anônimo), certifique-se que está configurado no Appserver;

Seção Proxy


5. Verifique a configuração de certificação (recomendamos habilitá-las);
[SSLConfigure] 
SSL2=1 
SSL3=1 
TLS1=1 
BUGS=0 
SecondCertificateClient=C:\TOTVS\TOTVSLicense2014\data\certs\licenseservercloud.cer 
Verbose=1 

6. Verifique se o endereço https://lscloud.totvs.app/apie a porta 443 estão liberados para o protocolo HTTPS e caso a sua empresa possua Firewall/Antivírus e/ou restrições de acesso à internet, é necessário que o administrador da rede libere o acesso. Uma forma de verificação pode ser realizada através do prompt de comando (CMD) utilizando o comando TELNET licenseservercloud.totvs.com.br 443.
Saiba mais

Para avaliar a comunicação entre o seu servidor de licenças e os servidores da TOTVS, siga as orientações do link abaixo:

Framework - Linha RM - Frame - Telnet e Tracert License Server Virtual

 

7. Verifique se no momento que o License Server é sincronizado se o servidor possui acesso a internet e todas as liberações conforme citado acima. Por padrão a sincronização é feita no período noturno (22:00 às 06:00).

 

8. A atualização automática é feita através do Job LSInit, com isso, certifique que possua a configuração conforme abaixo no seu arquivo appserver.ini da instalação do License Server;

[ONSTART]
jobs=LSInit
refreshRate=60

[LSInit]
Main=LSInitialize
Environment=Environment

 

Observação:

Caso utilize o Portal Corpore.NET, é possível configurar para que a mensagem 'A autorização de uso do sistema irá vencer' seja exibida apenas para os usuários Supervisores do sistema.

Para habilitar esta funcionalidade, assinale a flag 'Ao utilizar o Portal informar apenas ao Supervisor quando a licença estiver próxima de expirar.', nos Parâmetros Globais do RM, acessando a guia License Server:

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