Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - TOTVS BackOffice (Línea Protheus) - MI - Contabilidad de Gestión (SIGACTB) - CTBA010 - array out of bounds ( 28 of 27 ) on { || If(self:oBrowse:oData:aShow[Self:oBrowse:nAt,Len(self:oBrowse:oData:aShow[Self:oBrowse:nAt])], 16777215,Nil)

Ocurrencia
En el módulo de Contabilidad de Gestión (SIGACTB) al ingresar a la rutina de Calendario Contable (CTBA010), se presenta un error.log:

array out of bounds ( 28 of 27 )  on { || If(self:oBrowse:oData:aShow[Self:oBrowse:nAt,Len(self:oBrowse:oData:aShow[Self:oBrowse:nAt])], 16777215,Nil)}(FWFORMGRID.PRW) 26/05/2021 17:04:48 line : 3844


Ambiente
Cross Segmentos - TOTVS BackOffice (Línea Protheus) - MI - Contabilidad de Gestión (SIGACTB) - Versión 12


Causa
Se ha identificado que el error.log puede ser generado por desactualización de la rutina CTBA010 cuando existe integración con EAI a través de la validación del adapter (Rutina: CTBI012A) al realizar el bloqueo del calendario.



Solución
Para solucionar esta ocurrencia, realice los siguientes pasos:


1. Garantice tener la rutina CTBA010.PRW con fecha igual o superior a 19/02/2021 y CTBI012A.PRW  con fecha igual o superior a 17/02/2021; En caso de tener una fecha desactualizada, deberá solicitar la actualización (DSERCTR1-30661) a soporte Protheus Mercado Internacional vía ticket;


2. Sugerimos que descargue y aplique la ultima actualización del modulo de contabilidad disponible en el portal del cliente para la versión de su ambiente, para ser aplicadas en su ambiente de pruebas con previo respaldo del RPO y aplicando solo fuentes actualizados.

Ejemplo: 21-06-02_ATUALIZACAO_12.1.27_CTB_EXPEDICAO_CONTINUA.ZIP - https://suporte.totvs.com/portal/p/10098/download?e=959397


3. Aplique las actualizaciones en su ambiente de pruebas con previo respaldo del RPO;


4. Verifique tener creada la tabla CQD - Cross Segmentos - TOTVS BackOffice (Línea Protheus) - MI - Contabilidad de Gestión (SIGACTB) - CTBA010 - Bloqueo de Procesos - No se muestran los registros de procesos para el bloqueo en el browse;


5. Ingrese a la rutina de Calendario contable (CTBA010), realice el bloqueo de procesos en el calendario contable, valide que no sea presentado el error.log.

Cross Segmentos - TOTVS BackOffice (Línea Protheus) - MI - Contabilidad de Gestión (SIGACTB) - CTBA010 – ¿Cuál es la funcionalidad del Bloqueo por proceso en el Calendario contable?

mceclip1.png




Conozca más:

Para consultar la información contenida en nuestro banco de conocimientos, acceda al siguiente enlace: 

Cross Segmentos - TOTVS BackOffice (Línea Protheus) - MI - Contabilidad de Gestión (SIGACTB) - CTBA010 – ¿Cuál es la funcionalidad del Calendario contable?

 

Help On-Line - Calendario contable (CTBA010)

 

¿Fue útil este artículo?
Usuarios a los que les pareció útil: 0 de 0

0 Comentarios

Inicie sesión para dejar un comentario.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Rellene los campos siguientes para iniciar el chat:

Chat _