Ocurrencia
En el acceso al sistema Protheus se genera un error.log:
sigapss.spf: SuperFile Open error 12 - File: c:\totvs\erproot\protheus_
Ambiente
Cross Segmentos - TOTVS BackOffice (Línea Protheus) MI - Configurador (SIGACFG) - Versión 12
Causa
Este incidente puede ocurrir porque el archivo de usuarios sigapss.spf se corrompió.
Solución
Para solucionar esta ocurrencia, realice los siguientes pasos:
1. Detener el servicios del sistema Protheus;
2. Acceda a la carpeta protheus_data;
3. En la carpeta pswbackup, tendrá varias otras carpetas con la nomenclatura de la fecha de respaldo, acceda a la carpeta con el día anterior al problema y copie el archivo sigapss.spf;
4. Acceda a la carpeta del system dentro de protheus_data y cambie el nombre del archivo sigapss.spf que ya está allí y pegue este nuevo archivo que copió del punto 3;
5. Cambie el nombre de los archivos de ayuda (* .hlp * .hls * .hle) contenidos en la carpeta system del ambiente;
6. Garantice tener los archivos del Help Completos y Diferencial localizados para el país y versión/release de Protheus en la carpeta systemload contenida en el Protheus_Data del ambiente;
7. Reiniciar el servicio Protheus;
8. Se sugiere descargue el archivo de librerías acorde a la versión de su ambiente, 20-01-06-LIB_LABEL_06012020_P12; Aplicar las actualizaciones en su ambiente de pruebas inicialmente, con previo respaldo del RPO y eligiendo la opción "Aplicar solo fuentes actualizados";
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Ambiente 32 para versión/release 12117 o inferior
Portugués - https://suporte.totvs.com/portal/p/10098/download?e=899723
Inglés - https://suporte.totvs.com/portal/p/10098/download?e=899725
Espanhol - https://suporte.totvs.com/portal/p/10098/download?e=899724 -
Ambiente Lobo para versión/release 12.123 o superior
Portugués - https://suporte.totvs.com/portal/p/10098/download?e=899720
Inglés - https://suporte.totvs.com/portal/p/10098/download?e=899722
Espanhol - https://suporte.totvs.com/portal/p/10098/download?e=899721
9. Acceda al Configurador y verifique que el error.log ya no se presente.
Nota: Si el error.log se presenta para un usuario de Protheus en específico, deberá validar los siguientes puntos adicionales en el módulo configurador (sigacfg):
A) Menú: Entorno-> Registros-> Perfil de mantenimiento;
MP - CFG - PROFMGR - Perfil del usuario Mantenimiento (Profile)
B) Haga clic en buscar;
C) Seleccione este usuario que está dando un error;
D) Haga clic en Eliminar-> Seleccione la opción: Todos los registros de usuarios;
E) Realice una prueba accediendo nuevamente a la rutina que estaba dando error.
Conozca más:
Para consultar la información contenida en nuestro banco de conocimientos, acceda al siguiente enlace:
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