Ocurrencia
En el modulo de Libros Fiscales (SIGAFIS) se realiza el calculo del DIOT (FISA088), después el archivo del DIOT (FISA087), en la validación del archivo en el aplicativo del DIOT descargado de la pagina del SAT, es generado el error:
"Linea: XX Campo 7 - Nacionalidad: MEXICANA (Para este tipo de tercero NO es requerido"
Ambiente
Cross Segmentos - TOTVS BackOffice (Línea Protheus) - MI - Libros Fiscales (SIGAFIS) - Versión 12117
Causa
Este incidente ocurre por la incorrecta configuración del registro de países en la tabla SYA para el país de México.
Solución
Para solucionar esta ocurrencia, realice los siguientes pasos:
1.- Para la nacionalidad, la rutina FISA087 realiza la siguiente validación:
- Proveedores Nacionales
Alltrim(POSICIONE("SYA",1,XFILIAL("SYA")+(cAliasTmp)->CE8_PAIS,"SYA->YA_SGLMEX")),;//(cAliasTmp)->CE8_PAIS,; - Proveedores Extranjeros
Alltrim(POSICIONE("SYA",1,XFILIAL("SYA")+(cAliasTmp)->CE8_PAIS,"YA_NASCIO")),;
2.- Verifique tener la siguiente configuración que se muestra a continuación por APSDU, donde para el país México no tiene información en el campo YA_SGLMEX;
- Nota: Al final del articulo se anexa el contenido de la tabla SYA que se crea por estándar del diccionario de datos en un ambiente con sigamat a dos dígitos, con la finalidad que verifique sus configuraciones en su ambiente.
3. Verifique tener la siguiente configuración desde la rutina de países (COMA039), se muestra el ejemplo para el país 493 México y país 249 USA;
4.- Se incluye dos proveedores, uno nacional con RFC y uno extranjero con ID Fiscal de ejemplo - Ver archivo de validación P12117_5525175_DIOT_Extranjero_20190405.rar que se localiza al final de este articulo;
5.- Se incluye una factura de entrada para cada proveedor (Nacional y Extranjero), después se realiza la orden de pago para cada factura a través de la rutina FINA085A - Ver archivo de validación P12117_5525175_DIOT_Extranjero_20190405.rar;
6. Se genera el calculo del DIOT (FISA088);
7.- Se genera el archivo del DIOT (FISA087); donde no es generada la columna de nacionalidad para proveedores nacionales, que es lo correcto.
Nota: En caso de requerir apoyo para la revisión del un escenario especifico en su ambiente, deberá registrar un ticket de atención a Soporte Mercado Internacional, donde deberá anexar su vídeo de evidencia con el patrón de emulación y configuraciones a considerar.
Vídeo: ¿Como abrir un ticket de atención en el Portal del Cliente?
Conozca más:
Para consultar la información contenida en nuestro banco de conocimientos, acceda a los siguientes enlaces:
How To - Como responder la encuesta de satisfacción de tickets de atención TOTVS.
0 Comentarios