FAQs - Suporte técnico

RH - Linha Protheus - MEU RH - Processo para estabilização do app MEU RH

time.png Tempo aproximado para leitura: 00:05:00 min

Ocorrência
Presença de Lentidão, Quedas do serviço REST e/ou instabilidade durante o uso do Meu RH

Ambiente
TOTVS RH - TOTVS RH (Linha Protheus) - MEU RH - Todas as versões

Causa
Falta de atualização e inclusão de chaves de estabilização no appserver.ini do MEU RH

Solução
-> Passo 1
ATUALIZAÇÃO DAS BIBLIOTECAS DE FRAMEWORK (LIB) e BINARIO:
Atualizar as bibliotecas de framework (LIB):
LIB:
Harpia (12.1.33 e superiores): https://suporte.totvs.com/portal/p/10098/download?e=1050526
Lobo-Guará (12.1.27): https://suporte.totvs.com/portal/p/10098/download?e=989259

-> Passo 2
ATUALIZAÇÃO DO APPSERVER.INI:
Adicionar as seguintes informações abaixo no appserver.ini do serviço REST:
EnableKeepAlive=0 -> Adicionar na seção HTTPENV. Esta chave pode estar configurado também como HTTPURI

Exemplo:
[HTTPENV]
URL=/restT1
PrepareIn=T1
Instances=2,5,1,1
CORSEnable=1
AllowOrigin=*
Public=fwjwt/refresh_token,auth
EnableKeepAlive=0

A função da tag EnableKeepAlive é indicar que a conexão será encerrada depois da resposta à requisição.

Stateless=1-> Adicionar na seção HTTPV11. Com essa TAG só haverá consumo de licença quando a thread estiver em uso.

Abaixo segue os links das documentações de referência das TAG's mencionadas:
EnableKeepAlive: https://tdn.totvs.com/pages/releaseview.action?pageId=567770418
STATLESS:
https://tdn.totvs.com/pages/viewpage.action?pageId=527852596

Compression=1 -> Adicionar na seção HTTP (caso não possua SSL) ou HTTPS (caso possua SSL).

Exemplo:
[HTTP]
ENABLE=1
COMPRESSION=1

Para saber mais sobre a tag Compression, acesse: Compression

Em casos de ambientes que utilizam HTTPS/SSL, revisem as configurações com base no artigo: Informações adicionais para configuraçao de appserver

Caso utilize Broker no seu ambiente:
Adicione na chave do Broker HTTP/HTTPS a tag: USING_COOKIES=0

-> Passo 3:
ATUALIZAÇÃO DOS ARQUIVOS DO PORTALMEURH:
Os Arquivos do Portal sofrem atualizações periódicas e devem sempre estar de acordo com a versão dos fontes que está utilizando para evitar qualquer tipo de comportamento indesejado, inclusive quanto à performática do ambiente, portanto estar atualizado em todos os termos é extremamente recomendável e necessário para garantir a estabilidade do serviço.
Acessar o link a seguir e realizado o download conforme a release:
https://tdn.totvs.com/display/NPR/Passo+1%3A+Atualizando+os+arquivos

Importante: Deixar um backup do arquivo Properties.json. Após a atualização da pasta, copiar o arquivo de backup para dentro dessa pasta.

-> Passo 4:
INFORMAÇÕES IMPORTANTES:
É comum que o MEU RH possua uma configuração separada do ERP com RPO e binários exclusivos.
Portanto, como esse processo de atualização envolve bibliotecas de framework (Lib), tanto o repositório do Meu RH quanto todos os demais repositórios (RPOs) que apontam para o mesmo ambiente (Protheus_data e banco de dados) devem ser atualizados. Isso garante a integridade do produto.
Caso o problema de instabilidade persistir, abra um ticket ao time de suporte técnico, grupo de Meu RH com as informações listadas abaixo:
1. Arquivo com data das suas rotinas do RPO do Meu RH, conforme artigo: Como gerar arquivo com a data de todos os fontes do RPO?
2. Data dos arquivos do portal Meu RH
3. Arquivos appserver.ini e properties.json atuais, após os procedimentos deste artigo
4. Console.log demonstrando a tentativa de autenticação, conforme artigo: https://centraldeatendimento.totvs.com/hc/pt-br/articles/4416746889751
5. QRCode ou print da configuração do App no Celular (caso utilize via aplicativo mobile)
6. Informe se o erro ocorre apenas em dispositivos IOS, Android, ambos e/ou via browser

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