Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

RH - RM - FOP - eSocial - O campo 'qtdHrsSem' do registro 'horContratual' é obrigatório e não está preenchido

time.pngTempo aproximado para leitura: 00:01:30 min

Ocorrência
Ao realizar a geração do XML dos eventos S-2200S-2206 ou a validação da base de dados do S-2200, é apresentada a mensagem de erro O campo 'qtdHrsSem' do registro 'horContratual' é obrigatório e não está preenchido.

Ambiente
TOTVS RH - TOTVS RH (Linha RM) - Folha de Pagamento - eSocial - Todas as versões

Causa
Esse erro geralmente é apresentado quando o campo Número de Horas no cadastro de horário vinculado ao funcionário não está preenchido.

Solução
Para solucionar essa ocorrência, realize os seguintes passos:

1. Acesso o cadastro do funcionário Administração de Pessoal | Funcionário;
1.1. Acesse a aba Salário/Jornada no cadastro do funcionário e edite o Horário;

mceclip0.png

1.2. Certifique que o campo Número de Horas do horário esteja preenchido. Caso não esteja, verifique na aba Jornada se existe jornada informadas para o horário em questão;

mceclip1.png

2. Ainda no cadastro do horário, verifique na aba eSocial o campo Tipo de jornada e-Social;
2.1. Se tiver informado os tipos 3 ou 9, acesse o menu
Configurações | Parametrizador | eSocial | Configurações Gerais 3/7 ;
2.2. Caso o parâmetro Considerar jornada mensal do funcionário para cálculo da média de horas da Jornada semanal
(Tipo da Jornada: 3 e 9) esteja marcado, deve ser preenchido o campo Divisor da Jornada Mensal ou Fórmula do Divisor da Jornada Mensal.

mceclip3.png

 

Saiba mais
Para outras informações, acesse:
- Erro O campo 'tpJornada' do registro 'horContratual' é obrigatório e não está preenchido

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _