Tempo aproximado para leitura: 00:05:00 min
Dúvida
Ao realizar uma medição ocorre a Mensagem FWNOLIST para campo Competência na rotina de Medição CNTA121:
Ambiente
Cross Segmento - TOTVS Backoffice (Linha Protheus) - TOTVS Gestão de Contratos - Todas as versões
Causa
Esta ocorrência é comumente causada por inconsistências no Dicionário de Dados. Alterações não adequadas em Tabelas que envolvem o Contrato.
Por exemplo, alterada ordem de campos que funcionam com sequência lógica, alterado tamanho de modo incompatível, alterada a marcação de "usado" dos campos, dentre outras alterações indevidas.
Solução
1. A causa mais recorrente é a alteração na ordem (X3_ORDEM) de campos como: CND_NUMMED, CND_CONTRA, CND_COMPET e CND_REVISA
Verifique se os campos estão nesta ordem em seu dicionário e, se necessário, corrija.
2. Tendo validado a ordem, caso persista, confira que os campos estão devidamente marcados como "Usado" e visíveis para o módulo / para os usuários (não há retrições de acessos / níveis).
3. Caso ainda assim persista, é recomendado em ambiente/base teste recriar os dicionários, de acordo com o dicinonário padrão disponibilizado pelo produto no Portal do cliente, para certificar que, com o dicionário padrão, a ocorrência não é apresentada.
Segue para validação a ordem de todos os campos da tabela CND conforme o padrão nas imagens abaixo, e caso não esteja, realizar o teste com os campos na ordenação padrão do Dicionário de dados.
Obs:
Deve-se analisar na base de dados as ordens/tamanhos de campos tanto no Dicionário de Dados como também no Banco de Dados, os quais devem estar compatíveis.
Caso necessário, orienta-se o apoio de um analista especialista em loco para a analise da base de dados.
Saiba Mais:
0 Comentários