Tempo aproximado para leitura: 00:01:10 min
Ocorrência
Ocorrendo o erro 9445 Conta Corrente do Banco já existente ao criar um novo cadastro de conta corrente.
Ambiente
Cross Segmentos - TOTVS Backoffice (Linha Datasul) - Caixa e Bancos (CMG) - Versão 12
Causa
Esta situação ocorre porque uma conta corrente não poderá ser relacionada em dois cadastros.
Ao acessar o programa Conta Corrente - prgint/utb/utb099aa.r e informar uma conta corrente já existente no programa é apresentado o erro 9445 Conta Corrente do Banco já existente.
Solução
Deverá localizar o cadastro já existente com esta Conta Corrente Banco, e caso esteja cadastrado indevidamente, deverá alterar o cadastro já existente, relacionando uma outra conta corrente banco para desta forma poder utilizar a atual em um novo cadastro, ou realizar os ajustem necessários.
No nosso exemplo estamos tentando cadastrar a Conta Corrente Banco 123456.
Para localizar em qual conta corrente do Sistema a conta corrente do banco esta relacionada, poderá executar o Relatório Conta corrente - prgint/utb/utb308aa.r.
Deverá criar uma regra por conta corrente, deixando o inicial branco e final ZZZZZ para que seja apresentado todos os cadastros existentes, e então procurar no relatório a conta desejada.
No relatório gerado buscar a conta corrente do banco, que no nosso exemplo é 123456.
Aqui podemos ver que esta conta corrente banco esta relacionada ao conta corrente Sistema 2609.
No programa Conta Corrente - prgint/utb/utb099aa.r realizar o procedimento necessário para utilizar a conta corrente.
0 Comentários