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Ocorrência
Ao logar no RM ou executar processos ocorre o erro:
Login failed for user 'rm'.
Erro 1: Ao logar no RM
Erro 2: Ao executar processos no RM:
Login failed for user 'rm'.
Ambiente
Framework - Linha RM - Frame - Todas as versões do sistema RM
Causa
Esse incidente ocorre quando é alterada a senha do usuário rm de acesso ao banco de dados e não é reinstalado o serviço de host, ou quando a senha é alterada no banco de dados mas não é ajustada nos códigos de acesso no RM.
Solução
Para solucionar essa ocorrência, realize os seguintes passos:
Considerando o erro 1: Erro ao logar no RM
Após alteração da senha do usuário rm no banco de dados, é necessário reinstalar o serviço do host, através do aplicativo RM.Host.ServiceManager.exe, localizado em UNIDADE:\TOTVS\CorporeRM\RM.Net. Para mais informações sobre como reinstalar o serviço do host, consulte o artigo: Framework - Linha RM - Frame - Reinstalar host
Após efetuar esses procedimentos, será exibida a tela abaixo solicitando as credenciais para acesso ao RM:
O usuário e senha do usuário de acesso ao banco de dados não estão corretos. Você conhece as credenciais corretas para corrigir esta configuração?
Informe o usuário e senha utilizado no acerta usuário, por padrão, usuário rm e senha rm.
Essa mensagem ocorre quando o usuário e senha do banco de dados não estão idênticos ao da aplicação e vice versa.
Isso pode ter ocorrido por exemplo com a alteração do usuário RM dentro do sistema ou via banco de dados.
Assim no próximo login o sistema questiona se conhece as credenciais, entrando com o usuário correto do banco de dados o sistema realiza o ajuste e a mensagem não é mais exibida.
Caso não utilize a senha rm e tenha alterado a senha no banco, execute o script de acerta usuário alterando a senha de rm para a senha utilizada em seu ambiente, de modo a igualar a senha do banco de dados e a senha cadastrada no RM, pois a ordem de alteração de senha dever ser no RM e após no banco de dados. 
Abaixo os links para os script de acerta usuário:
Framework - Framework RM - BD - Acerta usuário ORACLE
Framework - Framework RM - BD - Acerta usuário SQL
Para mais informações sobre como alterar a senha de acesso ao banco de dados, consulte o artigo:
Framework - Framework RM - BD - Logins de Banco de Dados e alterações das senhas correspondentes
Atenção: Cuidado para não executar este procedimento em uma instancia incorreta, pois a alteração da senha do RM poderá impossibilitar o acesso ao sistema.
Caso tenha alterado a senha do usuário rm e deseja voltar a senha para o padrão (na qual a senha do usuário rm é rm), execute o script de acerta usuário e reinstale o serviço de host.
Considerando o erro 2: Erro ao executar processos no RM
Para correção dessa inconsistência, acesse o cadastro de códigos de acesso no RM e reescreva a nova senha, por padrão, senha rm:
Para mais informações sobre códigos de acesso, consulte o artigo abaixo:
Framework - Linha RM - Frame - Códigos de acesso
Reinstale o serviço do host.
Saiba mais
Para identificar qual usuário efetuou a alteração via sistema, poderá consultar o log de auditoria (habilitado para o objeto GACESSO) ou através da consulta a tabela GACESSO no banco de dados.
Via banco de dados é possível visualizar nas colunas RECMODIFIEDBY e RECMODIFIEDON, porém após qualquer usuário entrar com o usuário e senha do banco corretos será alterado com o nome do usuário rm.
Para mais informações sobre o log de auditoria, consulte o artigo:
Framework - Framework RM - BD - Habilitar novo Log de Auditoria
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