Tempo aproximado para leitura: 00:05:00 min
Ocorrência
Ao instalar o aplicativo mobile do SFA em um novo aparelho, ou efetuar o processo de reinstalação, a sincronização é interrompida na 4ª etapa e é exibido o erro abaixo:
Ao analisar o log de sincronização, o erro abaixo é apresentado no final do arquivo.
30/08/2022 11:42:00 - Fim da tranmissao. (Eof).
30/08/2022 11:42:00 - Fim da tranmissao. (Eof).
com.wealthsystems.sync.api.protocol.mstp.ProtocolException: Fim da tranmissao. (Eof).
at com.wealthsystems.sync.api.protocol.mstp.MSTPDataInputStream.readPacket(MSTPDataInputStream.java:92)
at com.wealthsystems.sync.api.ThreadBase.readFullPacket(ThreadBase.java:82)
at com.wealthsystems.sync.server.ThreadServer.run(ThreadServer.java:160)
Caused by: java.io.EOFException
at java.io.DataInputStream.readChar(DataInputStream.java:365)
at com.wealthsystems.sync.api.protocol.mstp.MSTPDataInputStream.readPacket(MSTPDataInputStream.java:71)
... 2 more
30/08/2022 11:42:00 - Tempo total (10 seg)
30/08/2022 11:42:00 - Finalizado!, Fechando ThServer...
Ambiente
Cross Segmentos - TOTVS CRM Automação de Força de Vendas (SFA) - Sincronização - Erro de sincronização cancelada - Todas as versões.
Causa
Esse incidente ocorre, pois, no momento da instalação do aplicativo, mais precisamente, ao conceder o acesso ao armazenamento interno e ao local atual do dispositivo, essas permissões ficam com a opção Durante o uso do app selecionada por padrão, quando na verdade, deve-se selecionar a opção O tempo todo. Abaixo, temos ama imagem para exemplificar essa situação:
Solução
Para solucionar essa ocorrência, realize os seguintes passos:
1. Acessar as configurações do dispositivo. Esse nome pode variar de acordo com o aparelho, seguem alguns exemplos: Config. / Configurações / Configurar;
2. Selecionar a opção relacionada aos aplicativos instalados, que pode variar entre os nomes: Apps / Apps e Notificações;
3. E, em seguida, selecionar Ver todos os XX apps ou Ver todos os aplicativos instalados;
4. Localizar o aplicativo;
5. Clicar na opção Permissões;
6. Para todas as opções que estiverem na aba Não permitido, é necessário selecionar o item e clicar em Permitir;
7. Geralmente nas permissões de Local e Armazenamento, é necessário clicar na opção Permitir o tempo todo, conforme a imagem abaixo:
Observação: O texto dessa opção pode variar minimamente de acordo com o aparelhos
8. Finalizar a instalação, e realizar uma sincronização;
0 Comentários