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Cross Segmentos - Linha Datasul - UFN - Erro 9972 na integração de cliente ou fornecedor

time.png Tempo aproximado para leitura: 00:02:00 min

Ocorrência
Ao integrar um cliente ou fornecedor ao financeiro ocorre o erro 9972:
Descrição: A Pessoa 13891 já está cadastrada como Cliente\Fornecedor !
Ajuda: A Pessoa 13891 já está relacionado com o Cliente\Fornecedor 800000048. Isto ocorre devido aos Parâmetros Gerais do EMS exigir Código único para Fornecedor e para Cliente.

Ambiente
Cross Segmentos - TOTVS Backoffice (Linha Datasul) - Financeiro Universal (UFN) – Versão 12

Causa
O erro ocorre quando não está sendo respeitada a regra de código único de cliente e fornecedor parametrizada nos Parâmetros Gerais do EMS - prgint\utb\utb101ta.r ao integrar um cliente ou fornecedor no financeiro:

mceclip0.png

Este parâmetro não pode ser desmarcado. Quando o mesmo é marcado indica ao financeiro que o fornecedor e cliente vinculados a uma mesma pessoa devem ter o mesmo código. Por exemplo temos a pessoa jurídica 13891 que está vinculada ao cliente 800.000.048. Ao incluir um fornecedor, vinculando a pessoa 13891, o código deste fornecedor somente poderá ser 800.000.048 que é o mesmo código do cliente que esta pessoa já está vinculada, qualquer código diferente ocorrerá o erro 9972.

mceclip1.png

No exemplo deste artigo estamos tentando incluir o fornecedor com o código 9.000.000, por isto ocorre o erro:

mceclip2.png

Solução
Para solucionar essa ocorrência:
1. Verifique no financeiro se já existe fornecedor\cliente com o código apresentado na mensagem de erro vinculado a uma outra pessoa. No exemplo deste artigo teríamos que verificar se já existe um fornecedor cadastrado com o código 800.000.048.
Se estiver incluindo um cliente verifique se já existe um fornecedor com o código apresentado na mensagem no Cadastro de Fornecedor - prgint\utb\utb031aa.r.
Se estiver incluindo um fornecedor verifique se já existe um cliente com o código apresentado na mensagem no Cadastro de Cliente - prgint\utb\utb107aa.r.
Se já existir um cliente\fornecedor com o mesmo código apresentado na mensagem e com outra pessoa vinculada, pule para o passo 3, se não prossiga no passo 2;

2. Verifique no módulo de origem se é possível alterar o código do fornecedor ou cliente para atender a regra de cliente e fornecedor único no financeiro. No exemplo deste artigo teríamos que alterar o código do fornecedor enviado na integração de 9.000.000 para 800.000.048. Se não for possível fazer o passo 2 prossiga para o passo 3;

3. Caso não seja possível efetuar o passo 2 ou já existe o cliente\fornecedor cadastrado com outra pessoa conforme passo 1 será necessário inutilizar a pessoa e fornecedor\cliente que já estão cadastrados e efetuar um cadastro novo de pessoa e também novos códigos de cliente\fornecedor;

3.1 Inutilizar a pessoa antiga. No exemplo deste artigo iremos inutilizar a pessoa 13891. Para isto alterar o Cadastro de País - prgint\utb\utb000aa.r para não validar o dígito de CNPJ ou CPF:

mceclip3.png

Alterar o cadastro da Pessoa Jurídica - prgint\utb\utb006aa.r ou Pessoa Física - prgint\utb\utb030aa.r para um CNPJ\CPF fictício:

mceclip5.png

3.2 - Cadastrar nova pessoa física ou jurídica com o CPF\CNPJ da pessoa que foi inutilizada.

mceclip6.png

3.3 Gerar novamente a integração no módulo de origem com um código novo de cliente\fornecedor vinculado a pessoa nova que foi criada. Este novo código de cliente\fornecedor não pode ser um código que já esteja cadastrado no Cadastro de Cliente - prgint\utb\utb107aa.r ou no Cadastro de Fornecedor - prgint\utb\utb031aa.r.

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