Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

RM - FOP - Integração RM Labore x BackOffice Protheus - HELP: REGNOIS

time.png Tempo aproximado para leitura: 00:02:57 min

Ocorrência
Ao realizar alguma integração entre o RM x Protheus, é retornado o erro AJUDA: REGNOIS.

Ambiente
TOTVS RH - TOTVS RH (Linha RM) - TOTVS Folha de Pagamento - Todas as versões

Causa
Essa incidência acontece pois os não há o registro de alguma informação que está sendo enviada na integração não existe no destino.

Solução
O erro que é retornado ao tentar incluir ou alterar algum registro quando se utiliza a integração RM x Protheus.
 
Quando tentamos inserir no Protheus por exemplo, com as mesmas informações que estão preenchidas no RM, irá retornar o mesmo erro como na print abaixo:



 
Isso ocorre pois algum registro que o RM está enviando não existe no Protheus, por exemplo:

Enviamos o funcionário com Centro de Custo de código 25 com origem no RM, mas no Protheus no cadastro de Centro de Custo existe só até o registro 24.
Dado o cenário acima é retornado o erro REGNOIS, direcionando a um entendimento por abreviatura como registro não existente.

Para solucionar o incidente, deve-se verificar o XML do erro através do artigo RH - RM - FOP - Integração RM Labore x BackOffice Protheus: Obtenção o XML mensagem de Resposta e Transformada no RM e identificando o campo no XML, será possível realizar o cadastro no ambiente destino.

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _