Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

RMS-INF Referência de objeto não definida para uma instância de um objeto.

time.png Tempo aproximado para leitura: HH:MM:SS min

Ocorrência

Ao abrir o atualiza ocorre a mensagem de erro abaixo:

Referência de objeto não definida para uma instância de um objeto

 

mceclip0.pngAmbiente


Retail Manager System, V22R01, V22R07.

Causa
É um erro genérico sendo necessário validar os passos abaixo:

Solução

Passo 1: Verificar se o usuário do banco tem as permissões abaixo:

Permissões de Acesso

  • Permissão ao usuário RMS para Connect
  • Permissão ao usuário RMS para Resource
  • Permissão ao usuário RMS para Unlimited Tablespace
  • Permissão ao usuário RMS para Connect e Resolve na ACL ¹
  • Permissão ao usuário RMS para acesso V$Session
  • Permissão ao usuário RMS para acesso Gv$Session
  • Permissão ao usuário RMS para executar Alter System ¹ ²
  • Permissão ao usuário RMS para executar Alter Session
  • Permissão ao usuário RMS para acesso Select Any Dictionary ²
  • Permissão ao usuário RMS para Debug Connect Session ²
  • Permissão ao usuário RMS para Debug Any Procedure ²
  • Permissão ao usuário RMS para executar Sys.Utl_Smtp
  • Permissão ao usuário RMS para executar Sys.Utl_File
  • Permissão ao usuário RMS para executar Sys.Utl_Tcp
  • Permissão ao usuário RMS para executar Dbms_Crypto
¹ Permissão exigida para recursos específicos do ERP.
² Permissão opcional, recomendado para análise de suporte e recursos de encerramento de sessão.


Passo 2: Verificar se a tabela 'GE_ATUALIZACAO' está populada com os dados, pois houve casos da mesma está sem informações das atualizações.

Para solução se faz necessário Insertar os dados com as primeiras versões seguindo o exemplo abaixo:

' SELECT * FROM GE_ATUALIZACAO FOR UPDATE'

mceclip1.png

Logo após abrir o atualiza, e o problema não vai ocorrer novamente. 

Esse artigo foi útil?
Usuários que acharam isso útil: 1 de 1

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _