Tempo aproximado para leitura: 00:02:00 min
Ocorrência
Faço alteração de preço em um determinado produto, mas o mesmo não está gerando etiqueta de preço, o arquivo de etiqueta (.ETQ) fica em branco.
Ambiente
Retail Manager System -RMS -Todas as versões.
Causa
Na tabela AA1DITEM o valor no campo DET_BLQ_ETIQUETA está com espaço em branco ou S.
Além disso esse campo gravado com espaço em branco ou S, impede a impressão da etiqueta do produto pelo VGVRETFZ.
Solução
Para resolver este problema, primeiro siga os passos abaixo:
1. Rodar consulta no banco para verificar se o campo está com espaço em branco ou S.
SELECT DET_BLQ_ETIQUETA FROM AA1DITEM WHERE DET_COD_ITEM = &CODIGO_DO_PRODUTO_SEM_DIGITO;
2. Se o resultado da consulta trouxer o campo com espaço em branco, acesse o RMS, VABUAITE, transação 03 e altere o valor para 'Não' o campo 'Blq.Emis. Etq'.
3. Se no VABUAITE o valor já estiver como 'Não', altere para 'Sim' Salve a alteração, depois volte no programa e altere para 'Não'. Fazendo isso o RMS vai forçar a gravação no banco na tabela AA1DITEM.
4. Se no resultado da consulta do passo 1 trouxer o campo com o valor igual a S, basta seguir o passo 2 alterando o valor para 'Não'.
Após seguir os passos acima o produto será exportado corretamente gerando o arquivo de etiqueta com conteúdo. Além disso não impedirá a impressão do arquivo de etiqueta através do VGVRETFZ.
0 Comentários