Tempo aproximado para leitura: 00:01:34 min
Ocorrência
Após a tela de login o produto apresenta a mensagem servidor encontrou um erro interno. O erro impede o uso do produto e começou a ocorrer após atualização de pacote. Os logs do Appserver e o catalina.out do produto Datasul for THF - TOTVS HMTL Framework não apresentam mensagens de erro.
Ambiente
Framework - Framework (Linha Datasul) - Tomcat – Versão 12
Causa
O servidor de licenças estava desatualizado. No arquivo de log localhost.<data>.log do produto Datasul for THF foi encontrado o seguinte erro:
java.lang.NullPointerException
at com.totvs.framework.license.LicenseManager.getLSVersion(LicenseManager.java:325)
at com.totvs.framework.license.LicenseManager.checkLSVersion(LicenseManager.java:182)
at com.totvs.framework.license.LicenseManager.checkLicense(LicenseManager.java:161)
at com.totvs.framework.license.LicenseController.checkLicense(LicenseController.java:104)
Ao acessar o Monitor de Licenças este apresentou a mensagem de que o License Server estava desatualizado.
Solução
Atualizar o License Server Virtual e reiniciar o serviço do produto Datasul for THF.
Saiba mais
Para a ver a versão atual do License Server e realizar a atualização consulte o artigo Framework - Linha Datasul - TEC - Verificar e atualizar a versão do License Server Virtual
0 Comentários