Ocorrência
Mensagem ao tentar gerar relatório em planilha xlsx: Não foi possível encontrar C:/[...].xlsx. É possível que ele tenha sido movido, renomeado ou excluído?
Exemplo no caso de MTR300

Ambiente
Cross Segmento - TOTVS Backoffice (Linha Protheus) - Estoque/Custos - Todas as versões
Causa
Esse incidente ocorre, geralmente, após alguma modificação nos diretórios que compõem a estrutura do ambiente Protheus.
Solução
Certifique-se de possuir o arquivo Printer.exe em todas as pastas Appserver do(s) ambiente(s). Caso não localize, copie o arquivo Printer.exe contido na pasta Smartclient e cole em todas as pastas Appserver
Caso os arquivos já estejam contidos nas pastas Appserver, outras análises que devem ser realizadas:
- O problema ocorre somente em um relatório específico? Se testar com demais relatórios o problema ocorre? Pois caso sim, o foco da análise deve ser em infraestrutura do ambiente, e em artefatos de infraestrutura (como lib/smartclient). Já se ocorrer com um relatório em específico, o foco da análise deve ser no código fonte deste relatório em questão;
- Certifique-se de estar com LIB e Smartclient atualizados;
- Verifique se o problema ocorre com um usuário em específico do Protheus, ou qualquer usuário tem o mesmo comportamento. Verifique também se ocorre testando em outro desktop/note (visto que o problema pode estar relacionado com o diretório físico);
- Abra o diretório indicado na mensagem (exemplo: C:\RELATORIOS\ ) e veja se foi gerado um arquivo nesse diretório. Caso sim, verifique se clicando com o botão direito, e em abrir, se abre diretamente no programa que executa este arquivo (exemplo: Excel) ou também não abre;
- Verifique se acionando a função Executar (exemplo: pressionando Windows+R no Windows) e digitando o programa que executa o formato xlsx (exemplo: digitar Excel) se o programa é normalmente aberto e executado.
Saiba mais:
0 Comentários