Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmento - Backoffice (Linha Protheus) - SIGAEST - SPEDFISCAL - TOP Error -19 - [ERROR] (from tDBServer::ROP_CREATEFILE - table K_K200_*******) Invalid operation with active transaction


time.png Tempo aproximado para leitura: 00:01:29 min

Ocorrência
Ao processar o SPED Fiscal com o Bloco K é exibido o seguinte error.log:

"TOP Error -19 - [ERROR] (from tDBServer::ROP_CREATEFILE - table K_K200_*******) Invalid operation with active transaction."

Ambiente

Cross Segmento - TOTVS Backoffice (Linha Protheus) - Estoque/Custos - Todas as versões.

Causa
Esse incidente ocorre pois o DBAccess não consegue fazer a chamada da criação do arquivo temporário K_K200_*******.

Solução
A última versão do DBAccess trata de contemplar o suporte a um novo tipo de tabela temporária, que pode ser acessada em modo compartilhado por múltiplas conexões, permitindo com que o processamento consiga gerar corretamente a tabela temporária inicial para o correto processamento dos Registros do Bloco K.

 

Para efetuar o Download desta versão do DBAccess, clique no link abaixo:

DBAccess atualizado

OBS: Sempre atualizar ambientes sempre em ambiente de homologação.

 

Saiba mais:

Clique aqui e veja mais artigos sobre Legais no Estoque

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

1 Comentários

  • Avatar
    Masut Administrador

    Já atualizei o DBAccess para a versão 21.1.1.4 ([DB: POSTGRES] / [Build: 20210202-20220603]) e mesmo assim continua apresentando o mesmo erro!

    -1
    Ações de comentário Permalink
Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _