Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Agro - PIMS CS - PIMS Web - Mensagem de falha de Runtime selecionarTodosModulosHabilitados

time.png Tempo aproximado para leitura: 00:01:00 min

Ocorrência
Ao acessar o PIMSWeb para verificar os agendamentos dos serviços, o Sistema apresenta mensagem falha de Runtime selecionarTodosModulosHabilitados.

Ambiente
TOTVS Agro – TOTVS Agro – Bioenergia – Manut Frotas - Lubrificação - MNF_LUB – Versão 12

Causa 
Esse incidente ocorre devido ausência dos scripts no arquivo de configuração no diretório de instalação do jboss.

Solução
Para solucionar essa ocorrência, acesse no diretório de instalação do jboss, o arquivo 
data\pimsserver\pimsserver.script e informe a query abaixo:

CREATE SCHEMA PUBLIC AUTHORIZATION DBA
CREATE MEMORY TABLE SCHEDULE_SERVICES(SERVICE_NAME VARCHAR(50) NOT NULL PRIMARY KEY,MODULE_NAME VARCHAR(20) NOT NULL,JNDI_NAME VARCHAR(50) NOT NULL,YEAR VARCHAR(4) NOT NULL,MONTH VARCHAR(3) NOT NULL,DAY_OF_MONTH VARCHAR(2) NOT NULL,DAY_OF_WEEK VARCHAR(3) NOT NULL,HOUR VARCHAR(3) NOT NULL,MINUTE VARCHAR(4) NOT NULL,SECOND VARCHAR(2) NOT NULL,ENABLED VARCHAR(1) NOT NULL)
CREATE MEMORY TABLE MODULES(MODULE_NAME VARCHAR(20) NOT NULL PRIMARY KEY,VERSION VARCHAR(30),FACTORY_JNDI_NAME VARCHAR(100),ENABLED VARCHAR(1) NOT NULL)
CREATE MEMORY TABLE LOGS(NOME VARCHAR(50) NOT NULL,CATEGORIA VARCHAR(250) NOT NULL PRIMARY KEY,NIVEL_PADRAO VARCHAR(50) NOT NULL,NIVEL VARCHAR(50) NOT NULL,DT_AGENDAMENTO TIMESTAMP,MAX_BACKUP VARCHAR(5),ROTATE_SIZE VARCHAR(10),TIPO_LOG VARCHAR(2))
CREATE USER SA PASSWORD ""
GRANT DBA TO SA
SET WRITE_DELAY 10
SET SCHEMA PUBLIC
Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _