Tempo aproximado para leitura: 00:02:00 min
Ocorrência
Intermitentemente o sistema apresenta um dos erros abaixo e é finalizado e ao acessar o TOTVS License Monitor no momento que ocorre a mensagem de erro no RM, o monitor não abre.
Exemplo erro 1:
Não foi possível renovar a licença.
Erro: 0
Mensagem: O License Server não respondeu em tempo hábil.
Exemplo erro 2:
Erro: (-10005) - O License Server não respondeu em tempo hábil.
Ambiente
Framework - Linha RM - Frame - Todas as versões do sistema RM
Causa
License Server desatualizado.
Solução
Para correção da inconsistência, siga os passos abaixo:
1- Pare o serviço do License Server nos serviços do Windows;
2- Na pasta data no diretório de instalação do License Server, renomeie os diretórios db_sys e db_tmp;
3- Na pasta licenseagreement, renomeie o arquivo totvslicenseagreement.key;
4- Adicione as chaves abaixo no arquivo appserver.ini (UNIDADE\TOTVSLicenseVirtual\bin\appserver\) do License Server:
[GENERAL]
GT_ReInsertAll=1
GT_ReInsertAll_time=300
5- Inicie o serviço do License Server nos serviços do Windows;
6- Acesse o License Server monitor e realizar a sincronização manual.
Importante
Caso a inconsistência persista, recomendamos a reinstalação do License Server utilizando o instalador mais atualizado, 3.6.0. Na atualização recente do LSV, houveram melhorias quanto a questão de comunicação, consumo de memória e processamento.
0 Comentários