Tempo aproximado para leitura: 00:04:15 min
Ocorrência
Ao tentar realizar o procedimento de troca de senha do usuário utilizando o Meu RH é apresentado a mensagem de erro, Não é possível enviar um e-Mail sem que o endereço do remetente seja informado. Por favor preencha o e-mail da Coligada, no Cadastro de Coligadas.
Ambiente
TOTVS RH - TOTVS RH (Linha RM) - Meu RH - A partir da versão 12.1.32
Causa
Falta de parametrizações no envio de e-mails nos Parâmetros Globais.
Solução
Acessar Ambiente | Parâmetros | Parâmetros Globais | Envio de E-Mails.
Os parâmetros devem ser preenchidos corretamente e então clicar sobre o ícone
para que seja realizado o teste de envio de e-mails.

Infelizmente existem fatores externos que podem influenciar neste processo, como conexão com a internet, firewall, antivírus, e outras aplicações que podem bloquear processos de envio de e-mail.
Fica a cargo do cliente analisar estes bloqueios externos e liberar que o aplicativo possa realizar o procedimento.
Importante
O RM necessita da configuração de relay habilitada, pois irá autenticar no servidor de e-mail com o usuário que está nas configurações globais e enviar como remetente outro usuário(definido nas configurações de parâmetros globais).
Observação
Em ambiente N camadas, o servidor de Jobs é o responsável pela execução dos processos, incluindo a rotina de processos que enviam e-mail. Dessa forma, considerando esse tipo de ambiente, deve-se realizar o teste de envio de e-mail no servidor de Jobs, e realizar as devidas liberações, quando for necessário bem como no servidor de aplicação.
Em ambiente local todas as máquinas de usuários que forem realizar o envio de e-mail, devem receber as liberações de segurança (Firewall, antivírus, proxy, e quaisquer outros aplicativos/configurações de segurança).
Saiba mais
Para obter informações adicionais, acesse o link: RM - Envio de e-mails
0 Comentários