Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Framework - Linha Datasul - TEC - Tentativa de conectar base de dados com nome ilegal ou nulo. (858)

time.png Tempo aproximado para leitura: 00:01:40 min

Ocorrência
Na execução do programa apresenta a mensagem: Tentativa de conectar base de dados com nome ilegal ou nulo. (858)

Ambiente
Framework - Framework (Linha Datasul) - Sessão Cliente – Versão 12

Causa
Pode estar relacionado a conexão de bancos de dados ou programa corrompido.

Solução
No primeiro momento avaliar a conexão de banco de dados:

1 - No arquivo .pf do AppServer deve constar todos os bancos, incluindo o emsfnd;
2 - O arquivo .pf da aplicação somente o banco emsfnd;
3 - O cadastro dos bancos por empresa no programa BTB962AA - - Parametros Foundation não deve ter o banco emsfnd cadastrado. Ele fica no .pf do broker Appserver e no .pf da aplicação conforme mencionado acima.

Persistindo, gerar um Clientlog da simulação da rotina conforme instrução do artigo Saiba mais e enviar para a análise do Suporte, pode ser programa corrompido.

Saiba mais
Conexões de bancos de dados no Datasul 12 Framework - Linha Datasul - TEC - Onde estão localizadas as conexões de banco de dados no ambiente Datasul for THF
Informações sobre o programa em Error (858), name is either null or an illegal name when connecting to database
Instrução para geração do Clientlog Framework - Linha Datasul - TEC - Como ativar o clientlog via arquivo .pf

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _