Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Framework - Linha Datasul - FRW - Erro: Falha ao carregar documento PDF ao tentar executar relatório BIRT

relogio.png Tempo aproximado para leitura: 00:01:30 min

Ocorrência

Ao executar relatórios BIRT -  Business Intelligence e Reporting Tools, é apresentada a mensagem Falha ao carregar documento PDF ao abrir o arquivo, e totvs.report.engineDir not defined or doesn´t exists no log do Tomcat ou no próprio relatório PDF - Portable Document Format ao abri-lo com um aplicativo de texto.

Ambiente
Framework - Framework (Linha Datasul) – Básico (BTB) - Todas as versões

Causa
Este erro ocorre pois os diretórios configurados nas Propriedades Relatórios do produto estão incorretos ou não foram preenchidos.

Solução
Para correção do erro, realize os seguintes passos:
1. Acesse o produto Datasul 12;
2. Na guia superior direita do browser acesse Configurações - Propriedades Do Sistema - Propriedades Relatórios;
3. No campo Diretório do engine do relatório informe o caminho do servidor Tomcat onde está instalado o BIRT, informando até a pasta ReportEngine. Por exemplo: c:\totvs\dts-1\instance-8080\birt-runtime-4-8-0\ReportEngine;
4. No campo Diretório dos templates de relatório informe o caminho do servidor Tomcat onde está localizada a pasta datasul-report. Por exemplo: c:\totvs\dts-1\instance-8080\apache-tomcat-9.0.31\datasul-report;
5. Reinicie o serviço do Tomcat.


Importante
1. A versão recomendada do BIRT para o ambiente Tomcat deve ser 4.6 ou superior.
2. Os diretórios devem seguir o padrão de cada Sistema Operacional com relação as barras e diretórios com maiúsculas e minúsculas ("\" ambiente Windows ou "/" ambiente Linux/Unix).
3. O usuário que inicia o serviço do Tomcat deve ter acesso aos diretórios configurados nas Propriedades Relatórios.

Saiba mais
Para mais informações, acesse a documentação disponível em Download de PDF - Datasul Tomcat.

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _