Tempo aproximado para leitura: 00:03:04 min
Ocorrência
Ao realizar a integração do sistema RM com o BackOffice do Protheus, retorna o erro AJUDA: ENTIDOBRIG e posteriormente o nome da entidade.
Ambiente
TOTVS RH - TOTVS RH (Linha RM) - TOTVS Folha de Pagamento - Todas as versões
Causa
Esse incidente ocorre, pois a parametrização do sistema Protheus está com campos obrigatórios que não são levados na integração com o RM. Na maioria dos casos o campo não existe no RM.
Solução
Para solucionar essa ocorrência o Usuário deverá verificar se o RM possui o campo para ser enviado no XML e caso não exista, deverá remover a obrigatoriedade do campo no Protheus para que seja possível integrar.
Um exemplo é o campo CT1_NATCTA referente à Natureza da Conta. O RM por padrão não leva esse campo na integração, caso seja marcada a obrigatoriedade no Protheus ele sempre esperará recebê-lo e retornará o erro de ENTIDOBRIG (Entidade obrigatória).
Para identificar quais campos são levados, pode-se obter o XML de Resposta da transação que retornou o erro e identificar o campo através das orientações: RH - RM - FOP - Integração RM Labore x BackOffice Protheus: Obtenção o XML mensagem de Resposta e Transformada no RM
Obtendo o XML de Resposta irá mencionar o campo que está ausente de preenchimento ou obrigatório no Protheus e não é levado na integração de forma padrão.
0 Comentários