Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - Backoffice RM - BI - Erro The Common Language Runtime


time.png Tempo aproximado para leitura: 00:02:00 min

Ocorrência

Erro ao tentar abrir Planilha .net em excel:

The common language runtime could not be loaded 

 

mceclip0.png

Ambiente
Cross Segmentos - TOTVS Backoffice (Linha RM) - RM BI - Todas as versões

Causa 
Este incidente ocorre devido ao .Net Framework incompatível com o Sistema Operacional ou desatualizado.

Solução

Para solucionar o incidente, siga os passos abaixo:

  1. Gentileza verificar a versão exata do componente Microsoft NET Framework esta de acordo com a 4.7.2, caso contrário realize a atualização da versão utilizando como base o site da Microsoft e posteriormente realize as verificações.
  2. No menu Iniciar, escolha Executar, insira regedit e, em seguida, selecione OK. É preciso ter credenciais administrativas para executar o REGEDIT.
  3. No Editor do Registro, abrir a seguinte subchave: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\NET Framework Setup\NDP\v4\Full. Se a subchave Full não estiver presente, você não terá o .NET Framework 4.5 ou posterior instalado.
    A pasta NET Framework Setup no Registro não começa com um ponto.
  4. Verifique se há uma entrada DWORD chamada Release. Se ela existir, você terá o .NET Framework 4.5 ou posterior instalado. Seu valor é uma chave de versão que corresponde a uma versão específica do .NET Framework. Na figura a seguir, por exemplo, o valor da entrada Release é 378389, que é a chave de versão do .NET Framework 4.5.


     
  5. A tabela a seguir lista o valor de Release DWORD em cada sistema operacional individual para o .NET Framework 4.5 e versões posteriores.

     

    Versão do .NET FrameworkValor da liberação de DWORD
    .NET Framework 4.5Todos os sistemas operacionais Windows: 378389
    .NET Framework 4.5.1No Windows 8.1 e Windows Server 2012 R2: 378675
    Em todos os outros sistemas operacionais Windows: 378758
    .NET Framework 4.5.2Todos os sistemas operacionais Windows: 379893
    .NET Framework 4.6No Windows 10: 393295
    Em todos os outros sistemas operacionais Windows: 393297
    .NET Framework 4.6.1Em sistemas com a Atualização de novembro do Windows 10: 394254
    Em todos os outros sistemas operacionais Windows (incluindo o Windows 10): 394271
    .NET Framework 4.6.2Na Atualização de Aniversário do Windows 10 e no Windows Server 2016: 394802
    Em todos os outros sistemas operacionais Windows (incluindo outros sistemas operacionais Windows 10): 394806
    .NET Framework 4.7No Windows 10 Creators Update: 460798
    Em todos os outros sistemas operacionais Windows (incluindo outros sistemas operacionais Windows 10): 460805
    .NET Framework 4.7.1No Windows 10 Fall Creators Update e Windows Server, versão 1709: 461308
    Em todos os outros sistemas operacionais Windows (incluindo outros sistemas operacionais Windows 10): 461310
    .NET Framework 4.7.2Na Atualização de abril de 2018 do Windows 10 e no Windows Server, versão 1803: 461808
    Em todos os sistemas operacionais Windows diferentes da Atualização de abril de 2018 do Windows 10 e do Windows Server, versão 1803: 461814
    .NET Framework 4.8Na atualização do Windows 10 de maio de 2019: 528040
    Em todos os outros sistemas operacionais Windows (incluindo outros sistemas operacionais Windows 10): 528049

     

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _