Tempo aproximado para leitura: 00:03:27 min
Ocorrência
Quando está ativa a integração entre RM x BackOffice Protheus, ao tentar realizar alguma rotina para ser integrada pode gerar o erro que será referente ao adapter utilizado.
Mensagem XXXXXXX não configurada ou configurada incorretamente para processamento pelo EAI
Ambiente
TOTVS RH - TOTVS RH (Linha RM) - TOTVS Folha de Pagamento - Todas as versões
Causa
Essa incidência acontece pois os não há o cadastro do adapter que foi utilizado pela rotina, tanto no ambiente RM quanto no ambiente Protheus, também pode acontecer de já existir esse cadastro mas de forma incorreta.
Solução
Para solucionar essa ocorrência, realize os seguintes passos:
1. É altamente recomendável, caso desejar criar automaticamente as versões tanto no RM quanto no Protheus, executar o Configurador de Integração através do sistema RM em EAI 2.0 | Configurador, essa rotina irá trazer os padrões para comunicação.
2. Caso realizar o cadastro manualmente, deverá acessar SIGACFG>AMBIENTE>SCHEDULE>ADAPTER EAI no Protheus e incluir o adapter que foi retornado no erro, caso já exista o cadastro deverá verificar se está configurado conforme o Manual de Integrações.
3. Para cadastro manual no RM, acesse Integrações | EAI 2.0 | Rotas. Caso já exista o cadastro deverá verificar se está configurado corretamente conforme o Manual de Integrações.
Para a versão do EAI 1.0 será utilizado o caminho Integrações | Mensagem Única | Integrações | Anexos | Mapeamento de Entidades.
Importante
Pode acontecer do sistema RM não ter as mesmas versões de adapter indicadas conforme tabela de adapter, mas no sistema Protheus deve seguir rigorosamente o cadastro sempre que possível.
0 Comentários