Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

RH - RM - FOP - eSocial - Erro ao gerar XML: A partir de 07/2021 não pode ser utilizada rubrica cuja natRubr em S-1010 seja igual a [1801, 9220]

time.png Tempo aproximado para leitura: 00:02:30 min

Ocorrência
Ao gerar o XML S-1200, S-1202, S-2299 ou S-2399 é apresentada a mensagem Erro evento 'xxxx': A partir de 07/2021 não pode ser utilizada rubrica cuja natRubr em S-1010 seja igual a [1801, 9220].

mceclip1.png


Ambiente
TOTVS RH - TOTVS RH (Linha RM) - TOTVS Folha de Pagamento - eSocial - Todas as versões.

Causa
O erro ocorre quando a natureza de rubrica enviada através da tag natRubr do S-1010 está com validade expirada ou o código está incorreto.

mceclip1.png

Desde o dia 23/05/2022 passou a ser obrigatório o envio dos eventos no Leiaute Simplificado S-1.0. Neste Leiaute, algumas naturezas de rubricas constam como expiradas, conforme Anexo I do Leiaute S-1.0. Exemplo:

​​​​

Solução
Para solucionar essa ocorrência, realize os seguintes passos:
1. Deve-se acessar a Tabela 03 - Natureza das Rubricas da Folha de Pagamento, e consultar quais os códigos de natureza válidos.  Os que possuem  data de término de vigência na coluna Término estarão expirados. 

mceclip2.png

2. Em seguida, acesse Folha de Pagamento | Administração de Pessoal | Eventos e localize o evento correspondente e informe a Natureza da Rubrica eSocial desejada;

mceclip0.png

3. Após, acesse o menu eSocial | Fila de Eventos e faça a edição do gatilho S-1010 gerado para o evento. Ajuste o campo Competência com o mês e ano igual ou anterior ao período de apuração que esteja enviando a folha/rescisão, para que a tag iniValid gere corretamente a informação de data:

mceclip0.png

4. Gere o XML novamente e envie ao eSocial.

Importante
A TOTVS não orienta qual natureza de rubrica deve ser informadas nas verbas, ficando tal escolha a cargo da própria empresa. 

Saiba Mais
Para saber mais consulte os links abaixo:

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _