Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.
Base de Conhecimento

Cross Segmento - Backoffice (Linha Protheus) - SIGAEST - MATA038 - Error.log "JOB threads doesn't support remote/visual components."

Cross Segmento - Backoffice (Linha Protheus) - SIGAEST - MATA038 - Error.log "JOB threads doesn't support remote/visual components."

Ocorrência

Ao fazer o processo de fechamento de Estoque na rotina Acompanha Custos (MATA038) é gerado um errorlog "JOB threads doesn't support remote/visual components."

 

Ambiente
Cross Segmento - TOTVS Backoffice (Linha Protheus) - Estoque/Custos - Todas as versões.

 

Causa

Ao executar a rotina de Acompanha Custos, e aparecer o errorlog abaixo:


Solução

Nesse cenário, é necessário aplicar o ultimo pacote acumulado para sua release.

https://tdn.totvs.com/pages/releaseview.action?pageId=522000602 

 

Quando o erro ocorre, e existe a chamada de uma função dentro do error log, por exemplo algum fonte com U_ é necessário validar se esse ponto de entrada, esteja tentando exibir componentes visuais em tela, Caso sim não será mais possivel na Acompanha Custos.

 

Os pontos de entrada existentes nas rotinas de fechamento continuam disponíveis, porém por conta da tecnologia utilizada, não permitem mais a apresentação de interface.

Caso você utilize algum ponto de entrada com abertura de tela, será necessário adaptá-lo para que ele trabalhe considerando que o processamento da rotina ocorrerá sem possibilidade de exibição de interface, como se fosse uma execução via schedule ou execauto. 

 

Saiba mais

Cross Segmento - Backoffice (Linha Protheus) - SIGAEST - O que é a rotina Acompanha Custos?

Cross Segmento - Backoffice (Linha Protheus) - SIGAEST - Validação para inicia a rotina Acompanha Custos

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Artigo fechado para comentários.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _