Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

RH - RM - FOP - Erro ao realizar transferência de funcionário "FKPFEMPRT_PCODEMPRT"

time.png Tempo aproximado para leitura: 00:01:36 min

Ocorrência
Ao realizar transferência de funcionário ocorre o erro:

The INSERT statement conflicted with the FOREIGN KEY constraint "FKPFEMPRT_PCODEMPRT". The conflict occurred in database "dbo.PCODEMPRT".

Ambiente
TOTVS RH - TOTVS RH (Linha RM) - TOTVS Folha de Pagamento - Todas as versões

Causa
O erro ocorre pois os códigos de empréstimo na empresa de destino não são os mesmos da empresa de origem.

Solução
Para solucionar essa ocorrência, realize os seguintes passos:

01. Acesse na coligada de origem da transferência, Administração de Pessoal - Cadastros Globais - Tabelas Dinâmicas;



02. Selecione Sistema: Folha de Pagamento e em Procurar por: selecione Código e digite INT30 e clique em ocultar registros para buscar;



03.  Após acesse a tabela e a aba; Item da tabela dinâmica;



04. Os códigos cadastrados devem ser cadastrados iguais na coligada de destino, exemplo, se na coligada origem tiver o código de empréstimo 30 empréstimo especial, na coligada destino também precisa ter o mesmo código cadastrado​​​.

Possui também a opção de copiar toda a tabela e enviar todos os códigos cadastrados para a coligada de destino, para isso; Selecione todos os códigos e em Processos - Copiar Tabelas Dinâmicas entre Coligadas;

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _